New

Allow us to change specific NVidia control panel settings permanently to fix stuttering issues (VSync on)

  • 14 November 2022
  • 6 replies
  • 546 views

I’ve a 360hz monitor and got some problems recently, since i tried heavier games with the new Power Upgrade. Many games are choppy / stutter alot for me.  By default, VSync is disabled via NVidia control panel and is also disabled again after every boot.

But for my configuration, i need VSync on to get a stable framerate.

My current configuration is:

  • Windows 11, 360hz using Shadow App.
  • 1920x1080 with 60FPS as Streaming Resolution
  • I’m using Nvidia’s frame capping feature to limit FPS to 60FPS on Shadow machine
  • I’m using “VSync on” via Nvidia control panel on Shadow machine

With this, i was finally able to get a fluid camera panning.

I found an older topic about this on reddit: https://www.reddit.com/r/ShadowPC/comments/eciubf/comment/fbd5i2y/?utm_source=reddit&utm_medium=web2x&context=3

So i’m not the only one with this issue. Maybe for some, VSync off and FPS uncapped is working fine, but for me, not.

We need an option to disable the NVidia configuration reset on every boot.

I’ve recorded a video about this, showing you the difference between VSync off and VSync on:

Btw. it could be possible that the internal anti tearing feature of shadow causing my issues. Maybe making this optional would be nice, too. GFN does have tearing in 120FPS mode doing a camera panning with the same game.


6 replies

Some additional notes: Frame capping(via RTSS or Max FPS of Nvidia) isn’t 100% needed. Also works with just forced VSync. In the Shadow app i’m using now 4-4-4, which will enable GSync for me, too.

Every game which can hold 60 FPS ist perfectly fluid on my 360hz monitor, now.

I got something else out of it. The VSync is especially important for Shadow users who can only play with 60 FPS streaming. So all with a monitor that can only 60hz.
All other users who have a higher refresh rate should also set a higher stream FPS.
I currently have a 360hz monitor. 360 FPS is not possible with Shadow, but 240 FPS is.
If I now set Shadow Stream to 240 FPS, even low FPS looks relatively smooth. If I restrict Elden Ring to 30 FPS, for example, it jerks very strongly in 60 FPS stream mode. But 30 FPS in 240 FPS stream mode looks great.

Windows 10 GPU Hardware Scheduling feature shouldn't be enabled. It’s off by default, but i’ve did some tests with this option. Its causing heavy stutters on high fps in some games. It was reproducible for me in Forza5 and Days Gone. When the frame time was on a specific level, the overall game stream was stuttering, even with >60 FPS. I’ve tuned that off, rebooted the system and this issue was gone.

Sorry for this self replying here. Tested alot in the last days, so maybe this can help others, too.

I’ve a 360hz monitor and got some problems recently, since i tried heavier games with the new Power Upgrade. Many games are choppy / stutter alot for me.  By default, VSync is disabled via NVidia control panel and is also disabled again after every boot.

But for my configuration, i need VSync on to get a stable framerate.

My current configuration is:

  • Windows 11, 360hz using Shadow App.
  • 1920x1080 with 60FPS as Streaming Resolution
  • I’m using Nvidia’s frame capping feature to limit FPS to 60FPS on Shadow machine
  • I’m using “VSync on” via Nvidia control panel on Shadow machine

With this, i was finally able to get a fluid camera panning.

I found an older topic about this on reddit: https://www.reddit.com/r/ShadowPC/comments/eciubf/comment/fbd5i2y/?utm_source=reddit&utm_medium=web2x&context=3

So i’m not the only one with this issue. Maybe for some, VSync off and FPS uncapped is working fine, but for me, not.

We need an option to disable the NVidia configuration reset on every boot.

I’ve recorded a video about this, showing you the difference between VSync off and VSync on:

Btw. it could be possible that the internal anti tearing feature of shadow causing my issues. Maybe making this optional would be nice, too. GFN does have tearing in 120FPS mode doing a camera panning with the same game.

Thanks for this, I was having random stutters every 3-5 seconds even though my latency and packets were fine. This completely fixed it however, should be a way to permanently enable this as you stated.

Found another reason, why vsync is important. When you force vsync via nvidia control panel on your shadow and you use low refresh rates, like 30hz or 40hz, then it still looks great and smooth. I think frame pacing on the client side (shadow pc app) is the key here. When every frame comes in a good frame pacing, it looks smooth enough to be playable. With low refresh rates, you can go on max on many games, even on callisto protocol (30hz). I made a video with miles morales in 40hz mode:

 

I’ve checked the 240 FPS Streaming mode again. With a local RTSS to check the frame times of the Shadow App, we can see much better frame times compared to the 60 FPS Streaming mode. I think, there is something which can be improved, so “low”-FPS gaming would still be good enough and would have less stutter.

 

Reply