Mouse 4 and 5 Buttons Stopped Working

Starting today (July 27th, 2021), my mouse 4 and 5 buttons stopped working on my shadow. (These are the two thumb buttons on the left side of the mouse.) I have experienced no other issues and these buttons have been working fine for the last year.

I am using the Linux Ubuntu App. I have replicated the same issue on two separate computers running Ubuntu 18.04. On both computers, I have tried two different mice on both the Official and Beta Shadow Apps. In all instances, the buttons continue to work fine on my local computers but are no longer recognized by my Shadow. I have tried the buttons in multiple Shadow programs with no success. The other mouse buttons still function (left click, right click, middle mouse click, middle mouse scroll).

Any help would be greatly appreciated. Thanks!

  • Application type: Ubuntu Linux

  • Shadow Client Version: Official and Beta

  • Local device CPU: Intel©️ Core™️ i7-4700MQ CPU @ 2.40GHz × 4

  • Local device GPU: Intel Corporation 4th Gen Core Processor Integrated Graphics Controller

  • Datacenter location: Chicago

  • Connection speed: 47.07 Mb/s down, 10.86 Mb/s up

  • Date when problem appeared: July 27th, 2021

  • Did you take any action(s) which could have created this problem?
    No. There were no updates or changes to my computers in the twelve hours between when the buttons were working and when they stopped being recognized by Shadow.

  • Do you use a VPN and/or antivirus? No VPN. Standard core Ubuntu security.



Q from Shadow 1 year ago

Hello @DarkPhoenix,

Glad to hear that it is now working on the beta applications. 

Thanks for being the best part of Shadow!

View original

10 replies

I’m using shadow on Arch linux.
I’m experiencing the same problem - both mouse 4 and mouse 5 buttons are not working. In addition, I’m having weird input issues: “stuck” keys (looks like key press up is not registered by Shadow), sometimes input keys are not registered at all (1 in 20, sometimes 5 in 20).

Userlevel 1

Try contacting shadow about it

Try contacting shadow about it

I did that as well. So far, they asked me to start my Shadow in Display Safe Mode, as well as try changing the resolution through the NVidia Control Panel. Neither had any effect. They also had me send them my Shadow and PC logs.

If anyone has any helpful ideas, please let me know.


I’m using Ubuntu 20.04 and having same issue. At first I though it was issue with the new games I was trying, but now I can confirm that it no longer works with games I’ve mapped to use both 4 and 5 buttons. I also contacted support about it. Hopefully if more of us report it, they can solve it sooner.


Please try the latest Linux beta app released today to see if that resolves your issues.

You can download it at

All the best!


Hey Steve and Everyone,

I have successfully tested that the Mouse 4 and 5 buttons work again on both the Alpha and Beta builds of the Ubuntu client. 

Thank you for getting this fixed. 

Hello @DarkPhoenix,

Glad to hear that it is now working on the beta applications. 

Thanks for being the best part of Shadow!

I never found a solution that make the button 4 and 5 working with my Logitech wireless mouse..

If there is a possibilty, I’m listening.

Hello @Nielle 

Have you tried out the Alpha and Beta clients yet?

I’m also unable to get mouse 4 and 5 (side buttons) to work with my G Pro Wireless. I’ve tried the regular client as well as the beta client