Rejected

Mouse/keyboard freeze when using other applications

  • 2 March 2021
  • 5 replies
  • 59 views

Issue/Describe the bug
On my Mac running the latest Big Sur, if I switch away from Shadow for more than a few seconds, mouse and keyboard input will stop working.  The video from the PC does not stop, and the PC is definitely still running, but no more mouse and keyboard input will work.  Luckily, simply clicking “restart stream” will fix the issue.

Applications/Devices:
Macbook Pro

Versions:
Client v 3.9.8

Steps to Reproduce:

  1. Run Shadow PC
  2. Switch to a different application for at least 1 minute.
  3. Return to Shadow PC
  4. Attempt to type or move the mouse.  Note mouse/keyboard are non-functional
  5. Open quick menu and click restart streaming
  6. Attempt to type or move the mouse. Note that mouse/keyboard are now functional.

Additional Notes

  • Running latest official Shadow PC mac client as of March 1, 2021.  Using MacOS Big Sur Version 11.2.1.  Of note, the Mac is connected to a dock by Thunderbolt 3, which is connected via wired ethernet to an Orbi WiFi satellite, which wirelessly connects back to the router.  Also of note, the mac host computer in question was connected via VPN to my work network, and thus was running with high latency.

  • As you might imagine, this isn’t my primary machine to use this from, so I am not looking for a solution.  So far, it works great on other machines.


Original Post:

On my Mac running the latest Big Sur, if I switch away from Shadow for more than a few seconds, mouse and keyboard input will stop working.  The video from the PC does not stop, and the PC is definitely still running, but no more mouse and keyboard input will work.  Luckily, simply clicking “restart stream” will fix the issue.

 

Steps to Reproduce:

  1. Run Shadow PC
  2. Switch to a different application for at least 1 minute.
  3. Return to Shadow PC
  4. Attempt to type or move the mouse.  Note mouse/keyboard are non-functional
  5. Open quick menu and click restart streaming
  6. Attempt to type or move the mouse. Note that mouse/keyboard are now functional.

Running latest official Shadow PC mac client as of March 1, 2021.  Using MacOS Big Sur Version 11.2.1.  Of note, the Mac is connected to a dock by Thunderbolt 3, which is connected via wired ethernet to an Orbi WiFi satellite, which wirelessly connects back to the router.  Also of note, the mac host computer in question was connected via VPN to my work network, and thus was running with high latency.

As you might imagine, this isn’t my primary machine to use this from, so I am not looking for a solution.  So far, it works great on other machines.


This topic has been closed for comments

5 replies

Userlevel 6
Badge +4

@robinmaypanpan Thanks for submitting the bug report.  Looks like you’re missing some information our devs need to look into this for you.

Please follow the template listed here: How Bug Reporting Works | Community (shadow.tech)

If you need a sample, check this out: Sample Bug Report | Community (shadow.tech)

Once you’ve edited your bug report to follow the template, we will reopen this thread.

Issue/Describe the bug
On my Mac running the latest Big Sur, if I switch away from Shadow for more than a few seconds, mouse and keyboard input will stop working.  The video from the PC does not stop, and the PC is definitely still running, but no more mouse and keyboard input will work.  Luckily, simply clicking “restart stream” will fix the issue.

Applications/Devices:
Macbook Pro

Versions:
Client v 3.9.8

Steps to Reproduce:

  1. Run Shadow PC
  2. Switch to a different application for at least 1 minute.
  3. Return to Shadow PC
  4. Attempt to type or move the mouse.  Note mouse/keyboard are non-functional
  5. Open quick menu and click restart streaming
  6. Attempt to type or move the mouse. Note that mouse/keyboard are now functional.

Additional Notes

  • Running latest official Shadow PC mac client as of March 1, 2021.  Using MacOS Big Sur Version 11.2.1.  Of note, the Mac is connected to a dock by Thunderbolt 3, which is connected via wired ethernet to an Orbi WiFi satellite, which wirelessly connects back to the router.  Also of note, the mac host computer in question was connected via VPN to my work network, and thus was running with high latency.

  • As you might imagine, this isn’t my primary machine to use this from, so I am not looking for a solution.  So far, it works great on other machines.

I did not see a way to edit the original, so I added the requested underlined headers in a reply.  Let me know if this is sufficient.

Userlevel 1
Badge

Hi @robinmaypanpan ,

 

Thanks for submitting this bug.

 

Could you send logs from your MacOS launcher when the issue occurs, and then reply here with your unique code?

 

https://help.shadow.tech/hc/en-gb/articles/360000541374-How-to-Send-Diagnostic-Logs-to-Shadow-Support

 

Thanks in advance.

Userlevel 1
Badge

Hello,

 

We were unable to reproduce this issue on our end and have not received a reply from you regarding the requested logs. This bug will now be closed.