Shadow Beta app on Nvidia Shield and chromebook doesn't recognize that the shadow is in beta mode

  • 12 February 2021
  • 13 replies

Userlevel 1

Issue/Describe the bug
When launching Beta app, prompts to change to Stable when it should just launch shadow

Chromebook and Nvidia Shield (same issue)

Beta v. 3.4.6

Steps to Reproduce:

Using an Asus Chromebook or Nvidia Shield,
shadow is currently set to "Beta" via my regular client.

  • I launch the app, and select the icon to launch my shadow and it asks me if I want to change from Beta to Stable.
  • I then close the app (I don't want to change from beta to stable)

Additional Notes


Ike from Shadow 2 years ago



This issue should now be resolved with today’s (March 2) update to the Android Beta app (3.6.1).

View original

This topic has been closed for comments

13 replies

Userlevel 1

Hmm.  This ended up in the wrong place, so can some one move it?  I can’t delete it.

Hello @rastyk, I’ve moved this over to Bug Reporting. 

Userlevel 1

Thanks Steve, I appreciate it!

My Shadow Beta is having a similar issue. The Beta app asked me if I wanted to convert to Beta. It went through it’s upgrade on the remote. Now, it continues to ask me if I want to switch to Beta even though I’ve already switched to Beta.

Userlevel 1

Thanks :).  So background is that I’m a new user to shadow (one week ) , and ended up in kind of a loop when I tried to change to beta to fix my USB mic dropout issue (Ubuntu app user mostly).  I was hung in some sort of a loop where neither alpha or beta app recognized my shadow, and it would uninstall 15, then 1 package, then reinstall 16 packages and then ask me if I wanted to switch to beta again.  I restarted the shadow, and the next day I saw the USB fix was on beta so I tried again, and got stuck in that loop for an hour or two? ( 5-10 loops like I described) until finally it was OK.  This is why I don’t want to switch back, not until this is all fixed.

I’m using the Mac client on Big Sur and the M1 Apple chip. 

I’ll try to run my client again in a bit. Maybe the remote needs to finish something?

I’ll update with what happens.

Userlevel 1

So it works great now with beta on Ubuntu and iOS.  Just seems to be an issue with android...

My launcher is now stuck on the “Updating Shadow” bit. Bummer.

hmmm… what is going on..


Today i opened my chromebook, and launched shadow as usual.

I am in the new beta program for chromebooks (android app)

It asked me to switch to alpha, accidently i clicked “yes”

so it switched to alpha.. 


i tried to launch shadow and it gives me the error codes and launching problems as before the beta

test update ofcourse.

so i deleted the app, installed a older APK file, and then i updated it back to the beta.


but now the problem stays! launching shadow, mainscreen visible, disconnect..

I cant find a way to fix this an repair this .. someone knows how to fix this?




It didnt switch back to beta.

Now i have it back on beta with a Beta apk file, at this moment its uninstalling files, then installing files..

it stays looping to update files and try to connect…  same situation as described above here i guess.




Userlevel 1
Badge +1



The dev team is aware of an issue with the update process when using the Beta app. It is likely related to this bug and is currently under investigation / being worked on. 

Hello guys , avoid to shift the Shadow Beta app to 3.4.6, stay in 3.4.4 to block the automatic shift on the play store for the moment as long as it doesn't solve the current problem ... If you have done it, you can do a manual reinstall, you will not get the message of switch Beta to official if you stay in 3.4.4, I strongly recommend it to chromebook users, if you don't want to lose access to the android app.

And please can you take from the android developer someone who knows about chromebooks because you're out of it, both on this hardware and you're really out of it with Android .... which is a real disaster compared to iOS ... when will we get a quality work ? 

Userlevel 1
Badge +1



This issue should now be resolved with today’s (March 2) update to the Android Beta app (3.6.1).