Resolved

Shadow fails to switch to beta version

  • 14 February 2021
  • 7 replies
  • 238 views

Userlevel 2
Badge

Issue/Describe the bug
Attempting to update my Shadow to use the beta version. It goes through the entire uninstall components (16), but then during the install components, it fails on number 4 always. I tried multiple times, each time the same error loop occurs.

Applications/Devices:
MacOS 10.15.7

Versions:
not sure:
Shadow Beta 5.0.865
or this 
Beta Launcher v4.22.9 Client v3.9.7

Steps to Reproduce:

  1. Shadow is not booted up
  2. Starting the shadow beta app
  3. Confirming the willingness to switch to the beta config
  4. Shadow beta uninstalls 1 of 16 components, then starts to install 1 of 16 components
  5. During the install components, it fails on number 4
  6. tried and retried this, without solution, always fails on installing component number 4.

Logs:
Your logs have been sent to us
We're on it! Share the following code with developers: VVJMWF

Additional notes:

The main reason I’m switching to the beta version is cause of the article mentioned below where it states trying out the beta could help for USB Peripheral connection issues. 

 

Ike from Shadow 8 months ago

Hi @JohnJcwsOnIG,

 

The known issue related to the prior app version release has been resolved.

However, a stuck update can still happen for other reasons that are unrelated to this specific root cause. If you’re experiencing any stuck update issues now, please contact support so they can help with your specific case.

View original

This topic has been closed for comments

7 replies

Same issue here, not sure whats going on

Userlevel 2
Badge

UPDATE:
After yet another try the Beta Launcher took more time then the other tries to install some components and against all odds it came through.

I was then able to test my USB peripherals issue with my joystick (Microsoft Extreme 3D Pro). The joystick was also recognized on my Mac, this time the checkbox for the USB forwarding on the Shadow Launcher did activate, but still nothing happens on my Windows environment, the joystick doesn’t give any connect sound in windows and isn’t available in games.

Regards,

Alain

 

Userlevel 1
Badge +1

Hi alainsobry,

 

This is currently a known issue with the recent Beta app/update. The dev team is aware of this issue and it should be fixed in the next beta app update.

 

For your USB peripherals issue, please create a new bug report thread and include a screenshot of your Quick Menu stats and USB Peripherals menu.

Userlevel 1
Badge +1

Hello,

 

This issue should be fixed now with the latest beta app updates for all devices (except Chromebook, which is a separate issue).

Userlevel 2
Badge

Hi Ike,

I’ve progressed since the original post, hence the update I shared.

I’m now back to my original issue, the USB peripherals that don’t connect anymore as described here.

I can however confirm I’ve been uninstalling & reinstalling the apps (normal, alpha and beta) numerous times in between then and now and I haven’t seen the blocking installer issue anymore as described here above.

Thanks for the follow-up!

 

Kinds regards,

Alain

I am having the same issue I am on windows 10 

Userlevel 1
Badge +1

Hi @JohnJcwsOnIG,

 

The known issue related to the prior app version release has been resolved.

However, a stuck update can still happen for other reasons that are unrelated to this specific root cause. If you’re experiencing any stuck update issues now, please contact support so they can help with your specific case.