In Progress

Shadows USB peripheral forwarding doesn't work anymore

  • 20 February 2021
  • 3 replies
  • 114 views

Userlevel 2
Badge

Issue/Describe the bug
Attempting to play Microsoft flight sim 2020 again on my Shadow but Shadows USB peripheral forwarding decided I wouldn't.
To be clear I tested multiple app versions (beta and normal) but always respected the steps noted in the 'to reproduce' section below. None of these versions allow me to use my USB joystick again.

the spinner keeps on going:



Applications/Devices:
MacOS 10.15.7



Versions:
(normal) Launcher v4.22.9 Client v3.9.8
Beta Launcher v4.22.9 Client v3.9.7


Steps to Reproduce:

  1. Shadow is not booted up
  2. Starting the shadow (beta) app
  3. Uninstalling the Shadows USB peripheral drivers
  4. Uninstalling the Shadows (beta) app
  5. Rebooting my Mac
  6. Reinstalling the Shadow (beta) app
  7. Reinstalling Shadows USB peripheral drivers
  8. Connect my USB joystick
  9. Click on the connect button for the USB forwarding for my joystick
  10. On the (normal) Launcher v4.22.9 Client v3.9.8 the spinner keeps on turning and the checkbox mostly doesn't activate. Sometimes it does.
  11. On the Beta Launcher v4.22.9 Client v3.9.7

Logs:
My logs : KPXKRT

Additional notes:

 

Ike from Shadow 8 days ago

Hello,

 

Thank you for reporting this. There is a known issue with USB Peripherals not working on Catalina and older MacOS versions since the last update. It is currently being investigated and worked on, and we’ll update you here when the issue is fixed.

View original

3 replies

Same problem for me since the last version (Launcher v4.22.9 Client v3.9.8).

Unable to use any USB device : Spinner keeps on turning and the checkbox doesn't activate.

 

Datacenter : Chicago

OS : OSX Catalina

 

Badge

Hello,

 

Thank you for reporting this. There is a known issue with USB Peripherals not working on Catalina and older MacOS versions since the last update. It is currently being investigated and worked on, and we’ll update you here when the issue is fixed.

Userlevel 2
Badge

Hey Ike,
 

Indeed I received feedback from the devs to tryout the Alpha version (Alpha Launcher V4.23.0 Client V3.10.1), but no solution there yet to my issue.

Thanks for the follow-up here.


Regards,

Alain

 
 
×
 
 
 

Reply