Solved

"Administrator Approval Required for Installation"


Morning All,

Really hope someone on here can help with this one as I haven’t found a single working solution online and Microsoft don’t seem to care.

 

Basically any game that is in the XBOX Game Pass (PC) app or Windows Store that states “Administrator Approval Required for Installation” will not update if it was installed prior to that note being added or install at all.

Example Gears Tactics was working fine until it needed an update and now the update won’t download. Uninstalling works but then you can’t reinstall as it won’t download.

Streets of Rage 4 does not have that note and installs and updates without issue.

 

I have reset my shadow, updated Windows completely and have all the latest drivers installed and the result is the same. Prior to this Steam, GOG, Epic and other launchers all worked fine with out issue.

 

Anyone have any ideas?

icon

Best answer by Jim29er 10 July 2020, 05:30

View original

18 replies

I should add that I tried this on my laptop, same build of Windows, all updates applied and it let me install the same games causing me a problem without any issue.

Can I ask if any Shadow owners are even using Game Pass on PC?

Userlevel 6
Badge +5

Yes people are using Game Pass on PC. You need to contact support and explain the issue to them, they are the only ones that can fix this. 

I’ve reported it to Microsoft but it won’t get treated like a support call, it will just go on the “ignore” pile which is why I would like to chat with people successfully installing and updating games from the Game Pass that are marked as “Administrator Approval for Installation Required”. I’d like to ask how they set-up and configured their Shadow for example.

 

I’ve request my Shadow reset 5 times now and everytime the same event occurs. If I switch to any other physical device I own they install fine. Same OS / Same Update Level. 

Userlevel 5
Badge +3

I should add that I tried this on my laptop, same build of Windows, all updates applied and it let me install the same games causing me a problem without any issue.


I’m trying to think why the behavior would be different on your Shadow VM compared to another, local computer. Just to confirm, on your laptop you are logging in to Windows with your Microsoft account “directly,” but on Shadow you are logged in with the “Shadow” user account, which has been “linked” to your Microsoft account in the user account settings, correct?

In other words, if you look at the “Your info” screen under Settings → Accounts on your Shadow VM, you see “SHADOW” with your MSA e-mail address underneath, and then the word Administrator underneath that?

Yes I’m logged in as an administrator. I’ve tried various combinations, my latest attempt was to get my shadow reset, create a new Microsoft Account to initially log in with, update (excluding feature update 2004) and then convert it to a local account. After that upgrade it from Home to Pro.

Once Pro upgrade complete create a new local account that I added into the Administrators group, signed in with that and attempted the install of those specific titles and it didn’t work.

The issue revolves around the statement that an admin account is required for install but I’ve exhausted every avenue. If I can’t get it working I don’t have much use for my shadow :(

Userlevel 5
Badge +3

Regarding the “Administrator Approval Required for Installation” statement on the Microsoft Store, can you paste a screenshot of that? I’ve been looking for that on the things I own, and not finding it.

Sure, I’ve made several screen grabs for my XBOX Support thread here : https://answers.microsoft.com/en-us/xbox/forum/xba_wowpc-xba_gowxb/xbox-game-pass-on-pc-not-updating-games-properly/e99bfb95-47d7-4fa3-9057-e84e120c18c5?tm=1588254982411&auth=1&rtAction=1594111750437

If you don’t want to go to the link then here it is below;

So games like Gears Tactics, Gears 5, State of Decay 2 all produce the same error and all share that message in common.

To see that text open the XBOX App in Windows 10 and just go to that games page where you would click install and see a brief summary.

I just tested again, they all fail but I could install Phoenix Point and Streets of Rage 2 without issue.

 

Userlevel 5
Badge +3

Okay thanks for that...so that message apparently only shows up in the Xbox app. I don’t have Game Pass, but I can look at “Games I Own” which only shows three games without that message. I’m going to “take one for the team” and join Game Pass, and see if I have the same experience on game(s) you called out. I won’t be able to do that until this evening.

Userlevel 5
Badge +3

So I signed up for Game Pass, installed the Xbox app on my Shadow VM, tried to install Gears Tactics, and got this:

 

Userlevel 5
Badge +3

And then this:

 

Userlevel 5
Badge +3

My issue smells like this one:

https://forum.shadow.tech/technical-assistance-7/xbox-game-pass-wont-download-games-719

Userlevel 5
Badge +3

Curiously, I was able to download/install a game (Gears Ultimate for Windows 10) which didn’t have the “Administrator approval...” tag. Perhaps these issues are related?

My issue smells like this one:

https://forum.shadow.tech/technical-assistance-7/xbox-game-pass-wont-download-games-719

I did see that and thought I would give it a try, not attempted yet.

Another thing I noticed is that some games don’t appear in the Windows Store “XBOX Game Pass” list of things you entitled to, Gears Tactics and Phoenix Point are missing but as I said one installs and one doesn’t, just stinks of an issue MS aren’t going to fix because there seems to be no recourse for getting help.

 

OK I’ve just shrunk my shadow HDD, C: has around 96GB and D: has 161GB.

Gears Tactics intalled without issue on D: 

Utterly bizarre what Microsoft are upto!

Badge +1

yep good old Microsoft always screwing things up:/

 

Had this same issue on my local pc at first couple days ago which i thought it was on my pc end cause i did put new hardware in it and stuff  ram and a nvme drive and just thought something unstable made stuff go wonky lol..   But nope  my nvme drive was on 8k cluster  from my old ssd image that i clone from and store apps wouldn't install but some would that didin’t have the admin require message.   

 

So i had to reformat my nvme drive on 4k and reinstall windows fresh…   Than i booted up shadow today and bang same thing and thought to myself whelp nothing was wrong with my local at all cause i thought it got unstable and mess up windows files..… Its Microsoft screwing up like always lol..

 

Haven't did anything to my shadow yet sense im about to sleep will work on it tonight and reformat my d: to 4k.

After weeks of trying finally got this to work

 

Shrunk my drive and created as new 70GB D drive, formatted as NTFS 4096, still wouldn't work

Ran WSReset.exe, still wouldn't work

Cancelled the installation, tried again still wouldn't work

Cancelled the Installation, tried to install State of Decay 2, that worked

Went back to gears tactics and tried again, downloaded fine

 

Now admittedly, there isn't much of a fix there but for me in order to get it to work needed a NTFS 4k drive, and that drive to not be blank

I'm having a similar issue with Dragon Quest XI. Except I think my problem with needing administrator approval is because my user account doesn't have access to C:/ProgramFiles/WindowsApps. Which I think may have something to do with how Shadow is set up? Idk. All I know it's not matter how hard I try the game doesn't seem to install properly at all.

Reply