DOSBox full screen not centered

  • 20 December 2020
  • 2 replies

I noticed that certain 4:3 ratio dosbox games don’t center horizontally when full screen. Has anyone found a solution for this? See the example below.



2 replies

Userlevel 4
Badge +4

That screenshot looks familiar. Arcanum?

Run Shadow in windowed mode and set the desktop resolution of your shadow to a 4:3 ratio. Put up something black or whatever on your desktop outside shadow.

Or try checking that your shadow’s drivers are up to date.

Final option, set the resolution of shadow’s desktop to the widescreen resolution that’s the same height as the dosbox, and then try.

Good luck.

I think it may be client related. The picture is horizontally centered on the iOS client, but not on the macOS client. Fixing the screen resolution to a 4:3 ratio does work, but I was hoping for a fix to the client; rather than a work around.