Solved

how do i reduce audio stuttering?


Userlevel 1
Badge

hi whenever i play any audio, my audio starts cutting out. i have my bandwidth on 70mbps (i have gigabit internet) , and Ive tried connecting directly to my router and using the 5ghz band, ive also tried using “prefer reliability” instead of “prefer speed”. any tips to make this stop? 

icon

Best answer by Snok 5 June 2020, 18:27

View original

19 replies

Userlevel 6
Badge +5

If you put your bandwidth to 5 does the issue continue to happen? 

Userlevel 1
Badge

thanks for the tip, but when i limited my connection to 5mbps, there is still audio stuttering.

Userlevel 6
Badge +5

Are you using Bluetooth headphones? Can you tell me the CPU and GPU of your local machine (the one that Shadow is run on) 

Userlevel 1
Badge

no bluetooth headphones, the laptop speakers or headphones w a 3.5mm input.

cpu a9-4920

radeon r7 graphics 

Userlevel 2
Badge +4

Hello,

 

At the time of this happening. Can you take a screenshot of your Shadow stats and send them to us. As well do a tracert or traceroute (Mac) from your local host to Shadow.

In the future, can you follow this template, it’ll help everyone here to get you the help you need. Thank you

https://forum.shadow.tech/technical-assistance-7/asking-for-help-guidelines-must-read-125

Userlevel 6
Badge +5

Did you try the beta/alpha clients as well? 

Badge
  • Application type: Happens on iOS, Android and Windows

  • Shadow Client Version: Official

  • Local device CPU: For Windows: i7-1065G7

  • Local device GPU: Nvidia 1650 GTX

  • Datacenter location: Santa Clara (I’m in Oakland)

  • Connection speed: 450mbps up, 45mbps down, 24 jitter, 22 ping

  • Description of issue:

I am also having this issue (small audio stutters every few seconds, no visible video stutter) across multiple devices (iPad, Android, Windows laptop). On the laptop, I’m showing 500mbps down, 50mbps up, 20 ms latency in the Shadow app.  In the diagnostics (Alt+M+O), it’s sitting at 60 fps, no packet loss, floating between 12 and 22 ms latency. I get it on my bluetooth headphones, and without. This happens on 50mbps or 5mbps, no discernable differance in how often it happens.

It’s a very small stutter of audio, every few seconds. The video doesn’t appear to stutter, but it makes playing almost anything pretty unbearable.

Userlevel 6
Badge +5

@Darthus Did you try the beta client as well?

Hello, Just logged on - likewise having an audio stuttering issue
 

+++

  • Application type: MacOS (Catalina 10.15.7)

  • Shadow Client Version: Official

  • Local device CPU: 2.6 GHz 6-Core Intel i7

  • Local device GPU: AMD Radeon Pro 5300M 4 GB & Intel UHD Graphics 630 1536 MD

  • Datacenter location (check status.shadow.tech) California

  • Connection speed (Datacenter speed tests EU: Paris | AMS or US: CA | TX |CH | NY) 50mbps and 5mbps

  • Description of issue: Audio Stutters

Other:

  • Date when problem appeared: 10/12/2020

  • Did you take any action(s) which could have created this problem? If so, what? Following instructions starting up service, minimal extra configuration.

  • Do you recall any action(s) you took after it happened? Left it alone and started troubleshooting.

  • Do you use a VPN and/or antivirus? No.

  • Please provide a screenshot of your shadow stats (Alt+Win+O). Also make sure it captures a timeframe when the issue has happened.

     


Dropping the max bitrate to 5 has no effect, dropping frame-rate to 30 also no effect.

Using TCP seems to solve it, but it does increase the lag - I’d prefer a solution that doesn’t sacrifice latency. Thoughts on what else I can try?

Perhaps there’s a mac setting that’s causing interference
 

  • Followup - Audio still stutters, but not as much using TCP
  • on TCP, Video starts to stutter, but now the stuttering seems to be balanced between Audio and Video
  • FYI I’m testing audio by logging onto twitch with OperaGX
    trying with Twitch and YouTube on Chrome produces the same effect. Even system sounds have that same stutter - hence I’m thinking it’s a connection or mac configuration issue rather than an app or Windows 10 issue.

    Here are the stats for when I’m using TCP:

     

Userlevel 5
Badge +3

@lt_bodhi_cooper is your Mac connected using WiFi or Ethernet? If WiFi, do you have the means to test Ethernet?

Thanks! I’m using ethernet, not wifi, on average 200 down / 20 up

By means to test, do you mean using wireshark or something like it? If it’s free software, I’m fine downloading and figuring it out. On the client app, it looks like I’m not getting any packet loss, so that’s got me baffled. Perhaps jitter? Problems decoding the codec? Don’t know how to test for that, but happy to try!

Userlevel 6
Badge +5

Try using Shadow off your intel iGPU, also tell us your ISP and modem/router name. @lt_bodhi_cooper 

Userlevel 5
Badge +3

@lt_bodhi_cooper indeed Lily’s suggestion is the best place to start. I”m not sure if you can specify which local GPU to use on a Mac, but if that’s possible it’d be good to know.

Your “volatile” latency when using TCP seems unusual.

thanks @Jim29er 
Router is NETGEAR Nighthawk X6S Smart WiFi Router (R8000P) - AC4000
ISP is Spectrum

I’m still searching for how to validate the GPU - but after trying it on another macbook pro, one with only a single Intel Iris Plus Graphics 655 1536 MB GPU, I’m still experiencing the audio stutter. I’ll report more info as I discover it. So far both devices encounter the same difficulty.

As for TCP - yes, because of the handshakes and overhead associated with resending lost packets in TCP, I’m not surprised the lag is noticeably worse, but that’s a separate issue. Perhaps though you mean how many spikes there are in latency in TCP - I just figured that was normal too. Caused by resend requests and the like?

@Lily Using a second macbook pro that only has an Intel iGPU, that one also experiences the same stutter.

And here’s the screenshot for the second MacBookPro that’s also experiencing the same issue

Userlevel 5
Badge +3

@lt_bodhi_cooperWhat is the make/model of your cable modem, and which state are you connecting from? Indeed the TCP will increase input lag, but the latency shouldn’t be that volatile.

I’m in Utah, testing from an old MPB connected via Ethernet (ISP is Comcast):

Here are my stats when using TCP:

And UDP:

 

Update: The Audio issues seemed to have resolved themselves. It is no longer stuttering, though nothing has changed on my end. Maybe the latest software update? Maybe an infrastructure change? IDK, but it’s working fine now.

Thanks for whatever improvements made that possible.

Reply