Shadow client's best settings on apple silicon

  • 20 July 2022
  • 5 replies


Hi there!

i’m using shadow from a week or so and i’ve setted my settings in this way

the result is great on my m1 macbook air, i have a gigabit fiber.

Anyway i’m still experiencing some video compression on my image, at a totally acceptable level but i’m wondering if maybe there’s some settings that can give a even more smoother experience.

5 replies

Userlevel 5
Badge +6

Hi @dodecore 

Everything you have set is great. Some helpful tips to get more out of your machine is to disable location tracking on the mac as that can time to time cause issues with shadow. Furthermore if you are on wifi if you switch to ethernet you should get a even better experience. -Gelgoog


Hey mate,

thank you! Yeah I already use the Ethernet cable while I still have to try the location tracking method although I’ve never experienced issues with connection stability.

Do you leave on default the decoder option? 

Userlevel 5
Badge +6


You can try different settings on the decoder to see if you get a better experience. One thing worth trying is switching from TCP to UDP under stream preferences. -Gelgoog 


UDP was not the greatest solution for me, in fact the stability of tcp protocol together with a fast connection result in much more clear image. As for now I’m pretty satisfied of the result.


Where can I change all these extra setting and also in the mobile app?