Virtual Desktop / Oculus Quest 2 / Steam VR lag black borders

  • 31 October 2021
  • 1 reply


I’m sure this is posted somewhere else but nothing else is working and I can’t see a comment that is helping. 

Im using Oculus 2 and Virtual Desktop on Steam VR the lag and black borders on both left to right when ever I turn my head and I really need help fixing it. I’ve tried YouTube videos and other forums and I can’t get to the bottom of fixing it. 
my laptop is a basic laptop which is why I use shadow as my laptop is not powerful enough for PCVR games, I use a PlusNet fibre optics router which I have enabled 5GZ on it, speed is 70mb

I’ve spent hours trying to research this with no luck what so ever, if someone could give me advise I’d really appreciate it. Even if it’s get a new router to 6 or what ever would be great. Also I’m not computer guy so technical stuff will go ever my head. 

thanks in advance. 

1 reply


I have been experiencing the same issue even with a strong internet connection. To solve it, you need to adjust the VR tartrate bandwith in Virtual Desktop.

When you are using Virtual desktop application in your occulus 2, you can see your PC screen virtually appearing. It allow you to access to the settings menu then go to streaming menu. Here on the bottom left, you will see a button which allows you to adjust the  bandwith allocated to the VR streaming.

I usually select a value around 55 or 60 and the streaming quality is good and the latency is low. If you select a higher value image quality maybe better (difference not really visible) but a lot of lag is appearing. You can see it when moving the head with the black borders when moving your head. If you use a low value, then the latency is low but VR stream quality is lowered too.