Community Workaround: High Latency on Virtual Desktop and ShadowVR

  • 18 August 2021
  • 1 reply
  • 202 views

Userlevel 1
Badge

Disclaimer: This is a community workaround (not official). Please advance at your own risk. 

Since about 30th June, people using the Paris datacentre have been experiencing really high latency but only while using Virtual Desktop or the VR app and not while using the desktop or mobile app.

If this is what you experience, try this simple fix!

If you just get a high ping in general, this will likely have no effect.

 

Step 1: On your Shadow, Open Settings (shortcut: win+x, n) then click "Network & Internet"

 

EPvL1KEBci77Ai-YrB8kC1sDfKj97DtkOCtXWAkx7Lb6HtWx07xJtBEbbxbJsMLNcWxBbEVoH_GTsL3Eq7A08QOo8g-BMb4hjWl7-k_z3VKFC2XYaIPxgOpCPdOxCmHVV70EirQD

 

Step 2: Click “Change adapter options”

 

jirKIuaa87b2es5svok3R7noTcxANemsearIgA0UAJetucehE4i5-atjLXohsfetdvOZuGmIhK3QDolQWTUA3huvx9DvSOssT8Sm3Xs-6PPgANPjNRn6dO7v91WVYDKSpr75zqsr

 

Step 3: Right click "Ethernet" and click "Properties"

 

6gqzPlIlmeH9CzYFhEMveM7Nz1JXOX0nhxKpXQV4SmfMjENjKtl0iplBwYZvlDYagH3-sowXQUsfLJ0WtOtWoCDp-SW6b9nSjzm3JuChLROJJHC1W_ShgnrOTDmvHIp2SV41gXJo

 

Step 4: Click "Configure…"

oHK41xXXWoMJOSxzuIZO0GMa_Dmt7eGFLRecpZCov-omK_YaFLUNEHmjWlxwLZgiS-thG4lrD4zm0_hZAn_ABJAXeOSL6GqjgFBBfJEmiZBQZQ0TkqFwrWAAK6HXI5NlJ_aTgnoT

 

Step 5: Find “Large Send Offload V2 (IPv4)” and change “Value” to “Disabled”

 

QCwxnCbc4lLhzg7hsJUwACPbNwGXFtcKiGVLr_loMXweoHpnVmJvT9PWy_ht2f2hyMrmBl7Gec5l3jeIdpYpQNyXEuVFg2u37ZxrWX09Gkf_EaBzI4is3XIMU2CePzcYa3ulnmSZ

 

The stream will break, so quit Shadow (Win+Alt+Q) and reconnect.

 

Quit the Virtual Desktop Streamer app and re-open.

 

Enjoy VR streaming without the insane latency!

 

If this doesn’t work, try disabling “Large Send Offload V2 (IPv6) too.

 

Many thanks to @Jamielamb#0279 on the Shadow Discord #vr-chat for figuring this out!

 


1 reply

Userlevel 2
Badge

Thanks for this, it was a game changer! Half life alyx running like a dream... Awsome! 

Reply