Community Workaround: High Latency on Virtual Desktop and ShadowVR

  • 18 August 2021
  • 13 replies
  • 2905 views

Userlevel 2
Badge

Disclaimer: This is a community workaround (not official). Please advance at your own risk. 

Since about 30th June, people using the Paris datacentre have been experiencing really high latency but only while using Virtual Desktop or the VR app and not while using the desktop or mobile app.

If this is what you experience, try this simple fix!

If you just get a high ping in general, this will likely have no effect.

 

Step 1: On your Shadow, Open Settings (shortcut: win+x, n) then click "Network & Internet"

 

EPvL1KEBci77Ai-YrB8kC1sDfKj97DtkOCtXWAkx7Lb6HtWx07xJtBEbbxbJsMLNcWxBbEVoH_GTsL3Eq7A08QOo8g-BMb4hjWl7-k_z3VKFC2XYaIPxgOpCPdOxCmHVV70EirQD

 

Step 2: Click “Change adapter options”

 

jirKIuaa87b2es5svok3R7noTcxANemsearIgA0UAJetucehE4i5-atjLXohsfetdvOZuGmIhK3QDolQWTUA3huvx9DvSOssT8Sm3Xs-6PPgANPjNRn6dO7v91WVYDKSpr75zqsr

 

Step 3: Right click "Ethernet" and click "Properties"

 

6gqzPlIlmeH9CzYFhEMveM7Nz1JXOX0nhxKpXQV4SmfMjENjKtl0iplBwYZvlDYagH3-sowXQUsfLJ0WtOtWoCDp-SW6b9nSjzm3JuChLROJJHC1W_ShgnrOTDmvHIp2SV41gXJo

 

Step 4: Click "Configure…"

oHK41xXXWoMJOSxzuIZO0GMa_Dmt7eGFLRecpZCov-omK_YaFLUNEHmjWlxwLZgiS-thG4lrD4zm0_hZAn_ABJAXeOSL6GqjgFBBfJEmiZBQZQ0TkqFwrWAAK6HXI5NlJ_aTgnoT

 

Step 5: Find “Large Send Offload V2 (IPv4)” and change “Value” to “Disabled”

 

QCwxnCbc4lLhzg7hsJUwACPbNwGXFtcKiGVLr_loMXweoHpnVmJvT9PWy_ht2f2hyMrmBl7Gec5l3jeIdpYpQNyXEuVFg2u37ZxrWX09Gkf_EaBzI4is3XIMU2CePzcYa3ulnmSZ

 

The stream will break, so quit Shadow (Win+Alt+Q) and reconnect.

 

Quit the Virtual Desktop Streamer app and re-open.

 

Enjoy VR streaming without the insane latency!

 

If this doesn’t work, try disabling “Large Send Offload V2 (IPv6) too.

 

Many thanks to @Jamielamb#0279 on the Shadow Discord #vr-chat for figuring this out!

 


13 replies

Userlevel 2
Badge

Thanks for this, it was a game changer! Half life alyx running like a dream... Awsome! 

Thanks! Was looking for solution for a long time. Half life now works like a charm

Badge

I literally can’t thank you enough. I've been trying so many different things…...for days…...to try and improve  virtual desktop. This was an instant fix!

Like all the replies before: thanks a lot! I did everything, but nothing helped! That was the final solution!!

I connect to the Dallas data center and have an unavoidable ~45ms ping due to my location-as per Shadow support. I have been having brutal lag and stuttering while playing Steam VR. These steps did not make a difference, but expanding on the idea I disabled everything in the Ethernet properties that had the word "offload" in it and setting my resolution to match the host device did it! Ping is the same but Half Life is running amazing now! 

I did this and noticed a difference, it made games playable but I still have the very annoying freeze every 3 to 6 seconds. I have pretty ok internet and I am able to play Shadow regularly at around 10 to 4 ms and when I play ShadowVR it all goes downhill. So yea, this helped needless to say and now I am able to somewhat play vr games.

I also turned max bitrate in the shadow settings to 5 and locked fps to 50. I also downloaded the Nvidia control panel per my gpu to make sure I was controlling resolution to 1080 instead of 4k. For me, I would rather have smooth gaming without stutter, than the 4k resolution skipping all over the place. Hope that helps! 

I also turned max bitrate in the shadow settings to 5 and locked fps to 50. I also downloaded the Nvidia control panel per my gpu to make sure I was controlling resolution to 1080 instead of 4k. For me, I would rather have smooth gaming without stutter, than the 4k resolution skipping all over the place. Hope that helps! 

Wait, so if you turn down the settings on shadow and then go into ShadowVR those settings will work on ShadowVR?

Thank you so much! I tried everything and was just about to go out and buy a graphics card. Works like a charm with <20ms latency now!

I also turned max bitrate in the shadow settings to 5 and locked fps to 50. I also downloaded the Nvidia control panel per my gpu to make sure I was controlling resolution to 1080 instead of 4k. For me, I would rather have smooth gaming without stutter, than the 4k resolution skipping all over the place. Hope that helps! 

Wait, so if you turn down the settings on shadow and then go into ShadowVR those settings will work on ShadowVR?

 

I believe so but I'm not certain. Seemed to be the case for me. 

oh my god, you saved my life. I hadn't been able to use vitual destop correctly for weeks and it was very frustrating. You are a magician. All my words of thanks will be few.

Thank you! Worked perfectly fine! I was pretty close to quit my subscription, but this workaround made me change my mind! Thanks!

I did this and noticed a difference, it made games playable but I still have the very annoying freeze every 3 to 6 seconds. I have pretty ok internet and I am able to play Shadow regularly at around 10 to 4 ms and when I play ShadowVR it all goes downhill. So yea, this helped needless to say and now I am able to somewhat play vr games.

Same here, every 10-20 seconds lag begins, gets worse, freezes for 1-2 seconds, then runs smooth for a few seconds again. What can I do? :/

Reply