Oculus Quest 2 "Starting VR Stream" Defaults to 2D Desktop Stream

Userlevel 1

On my Oculus Quest 2 I’m unable to start my VR stream. Was working just fine a few days ago. It starts off by saying “Starting VR Stream”, but for whatever reason it then goes to “Starting Desktop Stream”. And boots into the 2D desktop version were your device will not be detected. I’ve seen my shadow update and install the required environment drivers. I’ve also tried reinstalling the Shadow VR Alpha. I’m certain at this point there’s an issue on the backend of Shadow with their environment drivers. Other solutions I’ve read  from support/staff suggest resetting the entire machine. But I believe this is due to the fact the environment drivers are buggy and developers can’t pin point the issue. I wouldn’t want to lose my ~1TB of data I have on my Shadow Client. Purchasing a third party app such as virtual desktop is a flawed solution. I want to use the native app that Shadow has created. This is very frustrated as a end user. No customer wants to spend hours on end troubleshooting. I’ve spent more time now troubleshooting than actually playing the game. I want to enjoy the game I purchase and be able to use them. 

This topic has been closed for comments

11 replies

Userlevel 1

I got the same exact issue since yesterday. I had stopped playing for a week or two. I am not frustrated since this is still an alpha product. You can purchase virtual desktop if you want to but again this is an alpha app.

Same, I can’t buy vd, a solution ?

Userlevel 1

Another reason Shadow VR Alpha breaks. I noticed is when SteamVR pushes an update. Reinstalling SteamVR however won’t fix Shadow VR Alpha from booting to VR mode when using the native Shadow VR Alpha app. 

Same, I can not get Shadow VR app to start in VR mode on my Quest 1. It always defaults to desktop streaming. I even reset my Shadow and only installed steam to try to get things working. No luck.

Userlevel 1

Did anyone try contacting support about the issue?

I saw in another post that they are aware of the issue. I don't know if that means they are fixing it or not.

Userlevel 5
Badge +5

Hey @allannaz,
shadow support does not provide support for alpha builds (which the VR alpha is), so please stick to the forums and discord.

It started working for me a couple of days ago. Still a little bit of stutter and lag with a 260Mbps download speed but it is playable. It takes a few more minutes to load to install the Alpha drivers and uninstalls them when I use my Shadow PC from my laptop. 

Userlevel 1

Thanks I just tested, it's working for me too! 


Hopefully the shadow team notes down this issue, so that if we have something like this in the future. 


Hey everyone, To get around this bug....... Let it go into 2d desktop..... Then login to windows.... Wait for everything to stop loading and then use the switch to VR button on the top left. This has worked everytime for me. Even though it's annoying to have to do it..... This does work.



I paid $64 for Skyrim VR cant get it working any suggestions?