Steam VR not detecting headset, help?

  • 2 November 2021
  • 5 replies


Anyone else having problems with Steam VR not detecting Oculus Quest 2 headset after Steam updated their app last Friday? I belive Shadow`s software (Alpha) is not corresponding with Steam`s new software update. Any suggestions?


Appreciate all the help as I currently can not access the VR stream but only the 2D desktop. Ps: I know many are using Virtual Desktop – but until now I have been very happy using Alpha. And not interested going through the hassle of using AirLink – as my experience so far is Alpha should do the job with out any “extra” (VD and AirLink).


Thanks guys! Best regards, Kevin

5 replies

FIXED IT !!! WORKING PERFECTLY (for me at least) 


I loaded the desktop Shadow app on my PC and it converts to the Official version.

Then go back to the Oculus Quest 2 and load the Shadow Alpha app under Unknown Sources.

It will run updates for about 10 minutes then click on VR and it works.


Must have got something cached or knickers in a twist.   All working


Yes. It started to start Steam VR greatly! Much better performance than Oculus airlink method.


Agree. What version SteamVR do you have GodsGift and Jackis?



Yes Alpha is the best. Like @GodsGift suggested – I must have had something cached, as SteamVR worked perfect on Alpha last night.