Solved

Use of Mb, MB, Mbit is inconsistent and confusing

  • 30 September 2020
  • 6 replies
  • 194 views

Userlevel 2
Badge

Hi,

could you please make sure you use the speed notations correctly? I’m seeing Mb mentioned on the web, Mbit in the Shadow client, in the speedtest MB. Inconsistent and sometimes plain wrong (Mb is not a correct abbreviation for Mbit). Thanks

 

icon

Best answer by Jim29er 30 September 2020, 15:43

I’m annoyed by this kind of stuff too, but the Mb/s is correct. Little ‘b’ for bits, big ‘B’ for bytes.

View original

6 replies

Userlevel 5
Badge +3

I’m annoyed by this kind of stuff too, but the Mb/s is correct. Little ‘b’ for bits, big ‘B’ for bytes.

Userlevel 2
Badge

It seems better since the last update. I guess it is just not common in the Netherlands to write Mb/s but rather Mbit/s just to avoid confusion with MB/s. You are absolutely right though.

I have a 300 Mb/s connection. In the Shadow Client I can configure the bandwidth up to 70 Mb/s. Is it correct that these are Mb/s? So I can select the maximum with my connection:
300 Mb/s or 37.5 MB/s
Do you agree?

Userlevel 5
Badge +3

I have a 300 Mb/s connection. In the Shadow Client I can configure the bandwidth up to 70 Mb/s. Is it correct that these are Mb/s? So I can select the maximum with my connection:
300 Mb/s or 37.5 MB/s
Do you agree?


Your math is correct, but indeed the maximum bitrate you can set in the Shadow client is 70 Mbps. That’s actually a very high bitrate; you won’t find other streaming services using that much.

Userlevel 2
Badge

@elmero your connection is fast enough but from my experience it is actually not recommended to use the highest possible speed even if you have the bandwidth. Why? I can’t tell for sure but my guess is that the outbound connection to you can be impacted by the concurrent number of users on that datacenter. If everyone would max out their bandwidth setting it could potentially degrade the service. My experience with the defaults are pretty solid and even lowering the bandwidth to 40, 30 or 20 Mbit/s gave me a solid experience,  at least on my Apple iPad Air that has a resolution between HD and QHD. 

Try resetting to the defaults after an upgrade of the app. Then see what the experience is. If you experience issues lower the bandwidth instead of increasing it. You may be surprised. Let me know your findings. 

If I were on the Shadow product team I would put a story in the backlog that shows the overall statistics after a session and let the user know what bandwidth was used overall and a recommendation to lower or increase bandwidth after verifying with the user if the experience had been good or not so good. 

@elmero your connection is fast enough but from my experience it is actually not recommended to use the highest possible speed even if you have the bandwidth. Why? I can’t tell for sure but my guess is that the outbound connection to you can be impacted by the concurrent number of users on that datacenter. If everyone would max out their bandwidth setting it could potentially degrade the service. My experience with the defaults are pretty solid and even lowering the bandwidth to 40, 30 or 20 Mbit/s gave me a solid experience,  at least on my Apple iPad Air that has a resolution between HD and QHD. 

Try resetting to the defaults after an upgrade of the app. Then see what the experience is. If you experience issues lower the bandwidth instead of increasing it. You may be surprised. Let me know your findings. 

If I were on the Shadow product team I would put a story in the backlog that shows the overall statistics after a session and let the user know what bandwidth was used overall and a recommendation to lower or increase bandwidth after verifying with the user if the experience had been good or not so good. 

 

Thanks for your feedback. I will try this. 

Reply