Question

Cannot update some Xbox game pass previously installed on my shadow

  • 14 January 2022
  • 0 replies
  • 8 views

I have just tried to resume using Shadow after some time not connecting, as not having enough time to test/play games with requirements exceeding my local computer configuration.

Opening the Xbox app, I noticed that some of the games I had previously installed needed an update.

For some games, the update worked fine just selecting the game and clicking on the update button.

But for 2 specific games (Minecraft Dungeons and Medieval Dynasty), the update button just did not appear to work when clicked. No specific error was reported, it just did not work... 

For Minecraft Dungeons, which I had just inst installed, but never actually tested, I tried uninstalling/reinstalling the game and that apparently worked.

I guess I could just do the same for Medieval Dynasty, which I had started testing and for which I saved some games, as these should normally be saved in the Microsoft cloud (but I was not 100% sure).

But it seems a bit overkill to have to uninstall/reinstall a game each time an update is released and I really wonder what could silently block such updates…

Any idea?


0 replies

Be the first to reply!

Reply