Controller forwarding stopped working after upgrading to MacOS Ventura

  • 19 December 2022
  • 7 replies


  • Application type: Mac

  • Shadow Client Version: Official

  • Local device CPU: M1 pro

    • Local device GPU: M1 pro

  • Datacenter location: AMS

  • Connection speed: Not relevant

  • Description of issue:

I use Shadow with a Stadia controller to play on MacOS. Everything was working wonderfully until I updated to the new MacOS Ventura 13.0.1, afterwards the USB forwarding stopped working completely.

What happens is that I see my controller in the list of USB devices to forward, but clicking on the checkbox doesn’t work. Also the shadow host doesn’t recognise the controller.

I noticed something that didn’t use to happen previously when USB forwarding would work, when I click on the Stadia button, MacOS opens a list of installed games on my Mac, therefore I did some digging and it seems like with the new update they have introduced new improvements for gaming on Mac, and one of them is in the area of controller support, so my guess is that the way that Shadow previously took hold of my controller no longer works and MacOS keeps using it instead.

What have I tried without luck:

  1. Restart
  2. Reinstalling the driver (with restart)
  3. Connecting the controller before and after shadow starts

Best answer by slings 29 December 2022, 22:42

View original

This topic has been closed for comments

7 replies

Hello, I have to same issue here
Ventura 13.0.1


All controllers stopped working and if you manually try to set them(clicking on checkbox next to controller’s name) in the stream options, there is a buggy animation and nothing happens

@dodo I can confirm that the beta version doesn’t have the button problem, you can actually get the controller enable, but still the controller is not forwarded. I strongly believe the changes in Ventura that made it possible to control the operating system environment using the controller is messing with Shadow’s ability to forward the controller.

@dodo actually it worked with Beta (install it from here), I suggest you also give it a try, make sure you uninstall the USB drivers from the current version before upgrading to beta.

@slings Thank you so much, using beta version worked !



I upgraded to the beta. Here’s how it is now:

  • Connected via Bluetooth: Controller isn’t at all detected
  • Connected via USB-C: Controller is detected but produces garbled data (you can check using the Game Controller settings pane in Windows + also verified in BeamNG)

I’m on latest version macOS running on a first gen M1 MBP trying to connect a Switch Pro controller. I uninstalled and reinstalled the USB drivers, too.

Any ideas on how to work around this?

@bjornlll I think it's a good idea to try with creating a new topic for this, since your controller is recognized already, maybe you need to take more steps to make it work correctly. I personally use steam, in steam you can open the big picture mode and see if your controller is recognized and if yes, what your controller is recognized as, see this reddit post for example.


One thing to check is in the controller settings of Shadow, make sure Shadow doesn't show your controller's name (it's fine if it's shown in the USB list), because if it's shown that means the USB forwarding hasn't worked correctly.

Thanks, @slings. I’ve created a new post for this, linked below.