Question

Desktop latency 40ms VR 400ms

  • 26 December 2020
  • 9 replies
  • 1570 views

Badge

Runs great until I start a VR game. Even tested on Miscreated in 2d, worked great. 18ms ping to datacenter. 40 in virtual desktop. SOON as a game is initiated or even steam VR, boom, 400-500ms lag.


This topic has been closed for comments

9 replies

Userlevel 5
Badge +3

Since you have not followed the guideline of how to write a forum-post in the “Technical Assistance” section it is very hard to tell what the issue is. You should provide information like Computerhardware, VR headset, Bandwith, etc.

Best regards, 
Phobos

Badge

Ryzen 2600

16GB 3200

RTX2070XC 

Oculus Quest 2

Using shadow Ultimate system

Badge

Bandwidth is 50 MBPS

I’ve been having the exact same problem, tried every single trick I could find on Reddit and on the forum. About 20-30 seconds into launching even just SteamVR I get insane network latency. I wonder if they are throttling bandwidth because of high holiday usage. It would make sense because I get waves of latency where it’s fine and then it goes to 300+ and then back down. I’m hoping tomorrow it goes back to normal.

Badge

Yep exactly my problem. But I think it’s been an issue from the beginning. I never checked the latency of VD before while in VR to see what it was until the other day. I just upgraded to a Ultimate too...everything else is fine-just VR create horrible lag..haven’t tried any of the driver rollbacks as they are old tips but idk..we will see what happens I guess.

Virtual desktop was working great for me Christmas Day which is interesting. I just tried the shadow vr alpha app and latency is actually perfect, just has the stuttering performance issue they’re working on. Worth a shot if you don’t need to move your head around a lot in your game.

Badge

Now that the weekend is over I might try VD again later on.

Badge

I have the same problem. Did you find any solution?

Shadow VR alpha is working better in terms of latency than Virtual Desktop but it has the stuttering problem.

I have tried all tricks to lower Virtual Desktop latency but no success.

  • In Shadow Ultra y have around 45-50 ms latency
  • In Shadow Ultra, using Virtual Desktop, in Desktop mode, 60-70 ms latency
  • In Shadow Ultra, using Virtual Desktop, in VR mode, 180-250 ms latency

 

Same issue. Locally I have 75mbps down, 20 up. 15ms ping. Connected to my Shadow Ultra via virtual desktop from my Quest 2 my ping is around 30ms. Open steam VR and ping goes to 300-400ms and the game is entirely unplayable. Looking in the performance settings the virtual machine seems to only be connecting and sending over it's Ethernet connection at a meagre 15-20mbps. Not sure if that'll be anything?

Also any game I launch tells me my GPU and RAM are almost entirely used up. I have perhaps 5 games installed and no extra software other than virtual desktop. 

 

If there's no solution to this shortly I'll be in subscribing.

 

Package: Shadow Ultra 

Internet Down locally: 75mbps+ up 20+ Ping 15ms. Duplex dsl to fiber optic at the road.

Headset: Quest 2

Router: TPLink AX1500 with WiFi 6. Running 5GHZ, less than 6 feet from edge of playspace, only devices connected: Oculus Quest 2 and Cellphone.