Question

ELTIMA driver pop-up since Big Sur update

  • 22 November 2020
  • 19 replies
  • 5031 views

Userlevel 1

Hey there guys!

I have a problem which I think is concerning Shadow.

 

  • I am using a MacBook early 2016

  • Official Shadow Client

  • 1.3 GHz Intel Core m7 dual-core CPU

  • Datacenter is in Paris

  • Connection speed is more than 300 Mbps

  • Since I updated to Big Sur the following pop-up appears each time I start the system

 

If I click on relaunch the pop-up just comes back after a few seconds, If I click on disable it goes away. 

  • I tried looking in the Privacy settings as described in the pop-up but I can’t find anything related to the issue

 

Can you guys help me?


This topic has been closed for comments

19 replies

I have the same problem! Waiting for an answer here

Badge

I get the Security and Privacy thing too but I don’t have the disable/relaunch combo, I have simply close. This is a fresh install of Big Sur, not an upgrade. I’m guessing this has to do with the drivers for USB forwarding since when I look up Eltima Netgate, that seems to be what they do, they write software to send locally attached USB devices to remote computers.

Badge

I would love a response from Shadow here. I wold also love to be able to uninstall this component but I see no way to do so. They’ve removed the GUI that commercial licensees of Eltima’s product get so I can’t use their recommended method.

Same issue on macOS 11.1. Still no ‘allow’ prompt coming up in Settings>Security & Privacy. Response from Shadow would be great ...

 

Userlevel 1

From some other threads, the USB drivers are broken in Big Sur. Not sure if Eltima or Shadow has to make the fix. But they’ve disabled USB on Big Sur. The only tech suggestion I’ve seen from Shadow is how to remove that file so the pop up doesn’t appear. 
 

iIt’s quite an unfortunate and frustrating issue since I’m paying my $14.99 a month and I can’t use my joystick and throttle, rendering my Shadow essentially useless. They need to get this fixed. Seems like something that should not have been an issue. If a big OS upgrade is coming, make sure your app works on the new release ahead of time. 
 

I had opened a support ticket and was told there is no timeline for a fix. (And, of course, since I can access my Shadow, I’m not entitled to any sort of refund). 

The only tech suggestion I’ve seen from Shadow is how to remove that file so the pop up doesn’t appear. 

What file needs to be removed? Honestly I just don’t want to see the popup anymore since I don’t rely on any USB accessories.

Agree, Shadow really missed the ball on this one. It’s like they just didn’t bother to test on the new macOS at all.

Userlevel 1

Eltima has apparently updated their drivers, so I hope Shadow gets this taken care of soon. It would be enough to make me cancel my service if it’s not addressed by the next bill. 

 

 

Userlevel 1

I get a similar message on a new install of Catalina (10.15.7) as well. I can no longer use my controller, which is really unfortunate. I feel the same about whether I want to keep paying for a service I can’t really enjoy.

Put in support ticket multiple times. I’ve yet to even to get a confirmation that my ticket was received.

I was loving on Shadow. Kind of disappointed.

If you need to delete the software:

sudo rm -rf ./LaunchDaemons/us.electronic.eveusb.daemon.plist
sudo rm -rf ./Frameworks/EveUSB.framework

ps ax | grep -v grep | grep eveusbd
kill <pid>

 

Badge

USB peripherals for macOS Big Sur through ShadowPC …

 

After the Shadow Tech found out that removing this feature for macOS, their solved this issue and lowered incoming tickets malfunction of connected USB peripherals.

 

There was one update after the Big Sur challenges occur, just before the removal, that worked, and thanks to that developer who did that task back then. Maybe some of the management in Shadow Tech could get that developer back to the task of solving the USB peripherals for macOS Big Sur?

 

Sadly, search for a solution through internet, only give me a feeling of low, to zero, effort or interest from Shadow Tech to supply this feature again to macOS users, with updated operation systems on their mac’s.

 

As pointed out by @buetowmt in this thread, Shadow Tech get’s they’er money, also without this feature running, from mac users, so way use money on this?

MacOS Big Sur, 11.2.1 MacBook Air, 13-inch (mid-2013)

Shadow Boost

Same problem.  I followed the advice given, 

sudo rm -rf ./LaunchDaemons/us.electronic.eveusb.daemon.plist
sudo rm -rf ./Frameworks/EveUSB.framework

ps ax | grep -v grep | grep eveusbd
kill <pid>

But interestingly the process eveusbd keeps coming up with a new number every time I kill it.  

I have done searches for Eltima software and moved the Eltima files to a desktop folder and I can delete them too.  

 

The pop-up persists, often interrupting work and of course without any real resolution because the preferences do not permit us to activate it, as the preferences have no idea what Eltima is. 

Badge

I’ve been getting this everyday since I've updated to Big Sur, every few hours it pops up. Is there going to ever be a fix for this?

For the most part, this has worked for me:

 

Run with sudo:

rm -rf /Library/LaunchDaemons/us.electronic.eveusb.daemon.plist
rm -rf /Library/Frameworks/EveUSB.framework

After restarting the computer the KEXT Library frameworks are reloaded. If this doesn’t work, you may need to disable SIP via the recovery partition and delete all remnants of EveUsb. Just be sure to re-enable SIP before you continue using your computer for security and safety.

But interestingly the process eveusbd keeps coming up with a new number every time I kill it.  

Try:

sudo launchctl unload -w /Library/LaunchDaemons/us.electronic.eveusb.daemon.plist

That finally killed the process for me.

Userlevel 1

Hey all, I’m new to the forum. Not entirely sure how things work just yet.  I recently got a Mac Mini M1 and I had this exact issue for the past few weeks.  Lots of people have had this issue for months.  I actually solved it last night and I sent Shadow a detailed message, encouraging them to create a guide asap for anyone experiencing this issue on Big Sur.  If you’re all interested I’d love to try to help get your controllers connected into Shadow.  You won’t be able to use them, however, because Shadow has currently disabled the feature (which I think is due to so many people having this issue).

I will simplify my directions (it’s 3 simple steps) and I will post them here shortly. With any luck you can at least see that your controllers etc. will be registered in Shadow under the USB Peripherals Tab. And if there’s any issues I’ll help you troubleshoot.  Give me a few and I’ll brb with those instructions.

 

-Skip

Userlevel 1

To keep things simple, I will try to be right to the point. I’m finding that many people (myself previously included) are getting the notification shown in the initial post.  I got this notification at the login screen, however I didn’t have the option to “Relaunch” or “Disable Daemon” but to just simply “Continue”. It would show up briefly and whether or not I would click “Continue” it would just go away. I would also get a similar notification in the Shadow app client telling me that ELTIMA LLC drivers need to be allowed to install in System Security Preferences but there was no process awaiting approval there. This is because you need to boot into recovery mode and allow third party kernel extensions to run. I will list the steps below that I took with success.

 

Step 1.

Firstly, I found it helpful to remove shadow completely from my system.  I had all 3 clients (stable, Alpha and Beta) installed and assumed the app, pending approval to install drivers, was part of the problem with the notification in addition to the corrupted install process that won’t end until the ELTIMA LLC drivers are removed in the next step. I also performed this command (  "kmutil trigger-panic-medic --volume-root "/Volumes/<StartupDiskName>” ) found (here https://help.shadow.tech/hc/en-gb/articles/360019199240-How-to-Enable-USB-Drivers-on-macOS-Big-Sur ) in shadow support to trigger panic medic. However, if you have the ELTIMA LLC issue and cannot use or even register your controller/device with shadow, no steps after entering the command are likely to work for you. Follow their directions to enter that command in your CLI after uninstalling shadow, then proceed with my directions to solve your problem.

Step 2.

Here you must remove any trace of ELTIMA LLC from your computer. This will stop the notification from appearing (completely) and will allow you to then install the drivers AFTER enabling the kernel extensions in recovery mode listed in step 3. Follow these steps to remove all traces of ELTIMA LLC from your computer as well as eveusb controller drivers:

  1. Boot into Safe Mode by holding shift while your computer is booting. (Or however your machine boots into safe mode, do your homework first!)

  2. Open Finder.

  3. Navigate to /Library/Frameworks

  4. Delete the EveUSB.framework folder

  5. Navigate to /Library/LaunchDaemons

  6. Delete the file whose name starts with us.electronic

  7. Navigate to /Library/Extensions

  8. There are Directions in a couple forums that tell you to delete everything in the extensions folder, do not do this...Instead delete only files related to this situation (eveusb, 360controller, eltima etc., there should only be 2-3 files for you to delete in this folder and they are very obvious in name.  Deleting anything else not related to ELTIMA LLC or your usb controller might cause other programs to have driver issues and some software to malfunction and need to be reinstalled. So ONLY delete files related to this situation removing ELTIMA LLC.

  9. Navigate to /Library/KernelCollections

  10. There should be a .kc file called AuxiliaryKernelExtensions.kc — (likely at the bottom of the list) DELETE this file and EMPTY TRASH AFTER to remove all previously deleted files related to ELTIMA LLC from your PC.

  11. Power off (so that you may boot directly into recovery)

 

Step 3.

From here (powered off from the previous step) you will boot your system into the recovery environment.  For me on the Mini M1 it’s holding the power button in until a black screen appears with other options. Search for how your particular mac boots into recovery in Big Sur and do that. From the Startup Security Utility within Big Sur recovery mode (which does not present the same options as when logged in as a user/admin under System Security Preferences) you will be presented with the options to allow third party Kernel extensions as well as other unapproved extensions. Upon allowing the Kernel extensions, entering your password for security reasons and allowing the system to apply the changes, reboot back into the regular system.  You should no longer have a notification about ELTIMA LLC. This time when you install shadow and launch (before clicking start now) click the settings option in the top right, click “My Shadow” on the left pane and click “Install drivers”.  This time you should trigger the install of the ELTIMA LLC software again, and you will notice in your System Security Panel this time there is a process for installation waiting to be approved.  Once you approve this your drivers will successfully install and you will no longer get the dreaded ELTIMA LLC notification. 

 

For good measure right after this install I would reboot (although you might not have to). When you log back into shadow, you should see that your controller (and any other USB devices) now registers under their USB Peripherals tab.  For me both my wired Xbox controller and my external SSD appeared in this list.

Finally, I know most are aware but Shadow have disabled the ability to use the USB over IP option. I think people not being able to get the drivers installed properly on Big Sur might have caused them some issues.  They submitted my troubleshooting to the devs, so hopefully this will be put into a simplified guide for everyone suffering with it.  While we can’t use them yet, it’s good to have it set up for when they enable the feature, which hopefully after solution this will be soon. In the mean time I’m here to help you all troubleshoot and figure it out. I had my own struggles but because of that I figured it out and I can guide you all if you encounter any issues.

 

I also wanted to note several posts above that mention the following commands:

sudo rm -rf ./LaunchDaemons/us.electronic.eveusb.daemon.plist
sudo rm -rf ./Frameworks/EveUSB.framework

ps ax | grep -v grep | grep eveusbd
kill <pid>

 

Some people have had luck (a few maybe) doing this and removing the ELTIMA LLC notification. I did not. All killing the PID did for me was trigger the ELTIMA LLC notification again and allow the process to continue on. Don’t waste your time with this, follow my steps above. If you find that they’re not working, reach out to me, provide screenshots and any info you think would be useful. My screenshots are not the best because I took them while troubleshooting to share with Shadow. But if necessary, and they take too long releasing a guide for this, I can come up with something more adequate and to the point. I hope this helps everyone on the internet. 

 

This is what we get for installing windows on a mac

Le me:

Get tired of pop-ups every time I start the PC
Buy a mac
Works great

Install Windows on a Mac
Get pop-ups every time I start the Mac

 

 

With every macOS Big Sur update I get this message again.
As I also have installed “Commander One PRO” from Eltima, I reached out to their support.
Here is what they wrote:

1. Completely uninstall USB Network Gate - https://electronicassist.freshdesk.com/a/solutions/articles/44001312963
2. Load your Mac in recovery mode - ⌘ + R
3. Execute the following command via Terminal - kmutil trigger-panic-medic --volume-root /Volumes/<YourVolumeName> (with the full path you the Volume)
4. Reboot Mac again.
5. Install the latest version of USB Network Gate.
6. Adjust security settings to allow USB Network Gate to load its driver signed by Eltima LLC.
7. Perform another reboot and allow the driver to load again if OS will prompt such a warning again.

May work, may not work at all.  :dizzy_face:

Userlevel 5
Badge +3

Shadow Alpha version should have been updated to fix an issue (don’t know if it is that exact issue), but I guess one of you guys can try it. Alpha launcher is available on the shadow GER/FR/ENG discords.