Games And Video Judder/Jitter All Of A Sudden


Badge

Is anyone else having this problem? Every display setting has a bunch of judder, it wasn't doing this a few weeks ago. It started all of a sudden a week or 2 ago.

 

I'm using the app on the Nvidia Shield. A helpful solution would be if someone can link me to an APK of the Alpha or regular version. The Betais the only one I can find.

 

Thanks in advance

 


This topic has been closed for comments

13 replies

Badge

My Internet issues cleared up this afternoon; things are smooth now:

But this morning, when things were choppy:

And, when switching to TCP during the choppiness:

 

For me, Comcast is usually pretty solid, but I’ve definitely been noticing more issues in the last few months (I only have the ~230Mbps service). I also need to replace my cable modem...just haven’t got around to that yet.

Update

 

I'm pretty lost on a solution because everytime I solve/fix it it will start juddering later on. I have been able to pinpoint that the effects of the judder is better or worse according to the version of Shadow (beta/official) and the Nvidia driver you are using. I went back as far as December to downgrade the drivers and the problem was completely gone............ Until I updated the shadow back to the forced Beta (shield will force the switch to beta after a day or 2) and the problem resurfaced even worse than it originally was with the beta.

 

Whatever the problem is, ALL OF THIS IS RELATED.

 

I believe it's more related to the Shadow app because the Nvidia drivers have had 3 separate updates since the judder started and not a single update addressed the issue.

Userlevel 5
Badge +4

My Internet issues cleared up this afternoon; things are smooth now:

But this morning, when things were choppy:

And, when switching to TCP during the choppiness:

 

For me, Comcast is usually pretty solid, but I’ve definitely been noticing more issues in the last few months (I only have the ~230Mbps service). I also need to replace my cable modem...just haven’t got around to that yet.

Badge

@DetroitEWarrenwhat type of Internet do you have, and which ISP?

I started experiencing some extreme video choppiness with Shadow from the Shield TV a couple of days ago, and had the same experience from two different Windows PCs. I then started looking at Internet performance, and it’s currently poor (Comcast cable with an Arris SB6190 modem). My modem is one of those “Puma chipset” models that is prone to problems, but a restart (using Comcast’s website) usually clears things up. That hasn’t helped in the last couple of days...speeds are improving, but there is still a lot of packet loss occurring. The modem stats show a lot of errors. When this has happened in the past, I’ve just had to wait a few days for things to clear up.

When I switch the Shadow client to use TCP, the packet loss goes away (due to TCP retries), but the performance is awful, and the latency in the hundreds.

These issues can’t be seen from Shadow on the Shield TV because there is no proper Quick Menu functionality like on desktop clients.

The takeaway here is to always ensure that Internet issues aren’t part of the problems...they can come and go at any time.

I definitely have Xfinity also and damn you might be right, but I doubt I wouldn't notice it elsewhere using other things. Maybe I need to have them do a reset from the system. I have unplugged and things like that but I definitely but as far as I remember speed tests were normal.

 

I have the 1TB internet speed but Xfinity is known for only sending 100-300 to your location. I'm gone run a speed test when I get home

 

Userlevel 5
Badge +4

@DetroitEWarren what type of Internet do you have, and which ISP?

I started experiencing some extreme video choppiness with Shadow from the Shield TV a couple of days ago, and had the same experience from two different Windows PCs. I then started looking at Internet performance, and it’s currently poor (Comcast cable with an Arris SB6190 modem). My modem is one of those “Puma chipset” models that is prone to problems, but a restart (using Comcast’s website) usually clears things up. That hasn’t helped in the last couple of days...speeds are improving, but there is still a lot of packet loss occurring. The modem stats show a lot of errors. When this has happened in the past, I’ve just had to wait a few days for things to clear up.

When I switch the Shadow client to use TCP, the packet loss goes away (due to TCP retries), but the performance is awful, and the latency in the hundreds.

These issues can’t be seen from Shadow on the Shield TV because there is no proper Quick Menu functionality like on desktop clients.

The takeaway here is to always ensure that Internet issues aren’t part of the problems...they can come and go at any time.

Badge
  • Describe the bug (required)

    • Constant judder around on screen movement

    • Screenshots wouldn't show the issue

    • Everything on the app used to show motion smoothly, now it always judders for all forms of visual media.
       

  • Steps to reproduce the bug (required)

    • Start watching anything or start playing anything

    • Yes, bug occurs 100% of the time
       

  • Application/device, official or beta, and version number (required)

    • Current version of official and Beta Android app, has judder on both Nvidia Shield and the PC app on my Surface Pro 3
       

  • Additional Context

    • Provide any additional information here

      • Internet speed or technical things are not the issue, please don't ask me this again because it causes a lot of irritation.

      • The issue has been going on for exactly 1 month. 

      • Some online videos play somewhat smooth, some are unwatchable. Downloaded movies are unwatchable. Games are unplayable. The judder is very subtle in online videos, very noticable in downloaded movies, very noticable in games.

Userlevel 5
Badge +6

Hi @DetroitEWarren 

I see you have started troubleshooting this issue. But to help others help you completing this template out would help a lot.

 

Copy and paste the template below and fill it out in your post:

  • Describe the bug (required)

    • Provide a detailed description of the bug

    • Include screenshots if possible

    • Describe the bug behavior VS. the expected behavior (what should happen if working properly)
       

  • Steps to reproduce the bug (required)

    • Provide explicit step-by-step actions to re-create the bug.

    • Example:

      • 1. Start Shadow

      • 2. Plug in headset XXX

      • 2. Open the Quick Menu and go to Microphone tab

      • 3. Try to forward the headset’s mic

    • After these steps, does the bug occur 100% of the time? Or sometimes?
       

  • Application/device, official or beta, and version number (required)

    • Example: Windows official Launcher v4.14.19 Client v3.2.17
       

  • Additional Context

    • Provide any additional information here

      • Include relevant logs, DxDiag or specs of your computer, connection speedtest results, additional screenshots or video, etc.

      • The approximate date/time that you first started to notice the bug

      • Any other relevant info that could be useful

Feature request Template:

 

Copy and paste the template below and fill it out in your post:

  • Describe the Feature (required)

    • Provide a detailed description of the feature

    • If possible, see if you can come up with a valid solution for implementation

  • Any extra details you may want to put in specific to this feature. 

  • Application/device

  • Additional Context

 
Userlevel 5
Badge +4

@DetroitEWarren I haven’t tested that use case; I use a local NAS as a video content streaming source for the Shield. I’ve only ever used Shadow for games, and the streaming quality is decent for that (although not perfect)...I don’t think I’d want to rely on it for movies and TV stuff.

Badge

I’ve been doing some comparisons with Shadow between my Shield TV and Windows PC connected to the same TV/network gear this weekend.

For whatever reason, the choppy video I was seeing on the Shield a few weeks ago is no longer there. Comparisons with the testufo site and games are indistinguishable between the Shield and PC (both at 1920x1080 resolution).

I’m running the 3.6.4 beta client on the Shield, and the beta client on Windows (Launcher 4.23.14, Client 3.10.16).

Man this sucks because I downloaded the regular app that's not the Beta and I'm having the same issues but it seems only with movies/videos downloaded to the Shadow desktop. They jitter bad, really bad, it's unwatchable. It used to be damn near as smooth as using Plex straight thru the Shield, I pretty much used Shadow for all my TV watching and downloaded all my movies on there.

 

The funny thing is that on the beta app, it jitters in games, online video streams and is much worse with downloaded videos. With the basic app, I only see the jitter with downloaded movies.

 

When I start the app on my Surface Pro, it seems that movies are jittering there also and that's a whole different device.

 

I have no idea what the cause of this could be 

 

Userlevel 5
Badge +4

I’ve been doing some comparisons with Shadow between my Shield TV and Windows PC connected to the same TV/network gear this weekend.

For whatever reason, the choppy video I was seeing on the Shield a few weeks ago is no longer there. Comparisons with the testufo site and games are indistinguishable between the Shield and PC (both at 1920x1080 resolution).

I’m running the 3.6.4 beta client on the Shield, and the beta client on Windows (Launcher 4.23.14, Client 3.10.16).

Userlevel 5
Badge +4

@DetroitEWarren thanks...I’m gong to have time to test things this weekend as well.

Badge

Nevermind it updated the regular version to the current one. Good looking out bro 💪🏽.

 

I'm about to test it out now

Badge

Yes, I think the issue was introduced in the 3.6.x branch, but I haven’t done the comparisons yet.

You can download (and then sideload) older versions from https://www.apkmirror.com/apk/blade-group/shadow/

Please also see

 

Wouldn't the app automatically force me to update to the Beta if I downloaded the old version of the regular app?

Userlevel 5
Badge +4

Yes, I think the issue was introduced in the 3.6.x branch, but I haven’t done the comparisons yet.

You can download (and then sideload) older versions from https://www.apkmirror.com/apk/blade-group/shadow/

Please also see