Solved

Getting Error Code R-300 on Dell XPS 9300 with latest Intel Iris Plus Graphics Drivers

  • 17 August 2020
  • 1 reply
  • 211 views

  • Application Type: Using Shadow.AppImage on Manjaro Gnome (Kernel: 5.7.14-1-MANJARO)
  • Shadow Client Version: Client v3.2.20
  • Local Device CPU: Quad Core Intel Core i7-1065G7
  • Local Device GPU: Intel Iris Plus Graphics G7 (Ice Lake)
  • Data Center Location: Chicago
  • Connection Speed: 800~mbps down, 60 mbps up.

Technical Details about my Machine: (sourced via running `inxi -Fxxxz` in terminal.

System:
Kernel: 5.7.14-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.1.0
Desktop: GNOME 3.36.4 tk: GTK 3.24.22 wm: gnome-shell dm: GDM 3.36.3
Distro: Manjaro Linux

Machine:
Type: Laptop System: Dell product: XPS 13 9300 v: N/A serial: <filter>
Chassis: type: 10 serial: <filter>
Mobo: Dell model: 0WX9VX v: A00 serial: <filter> UEFI: Dell v: 1.0.11
date: 05/08/2020

CPU:
Topology: Quad Core model: Intel Core i7-1065G7 bits: 64 type: MT MCP
arch: Ice Lake rev: 5 L2 cache: 8192 KiB
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
bogomips: 23968
Speed: 1296 MHz min/max: 400/3900 MHz Core speeds (MHz): 1: 1196 2: 1155
3: 1181 4: 1126 5: 1196 6: 1121 7: 1195 8: 1166

Graphics:
Device-1: Intel Iris Plus Graphics G7 vendor: Dell driver: i915 v: kernel
bus ID: 00:02.0 chip ID: 8086:8a52
Device-2: Realtek Integrated_Webcam_HD type: USB driver: uvcvideo
bus ID: 3-9:3 chip ID: 0bda:58fe serial: <filter>
Display: x11 server: X.org 1.20.8 compositor: gnome-shell
driver: modesetting alternate: fbdev,intel,vesa
resolution: <xdpyinfo missing>
OpenGL: renderer: Mesa Intel Iris Plus Graphics (ICL GT2)
v: 4.6 Mesa 20.1.5 direct render: Yes


Description of my Issue:

  • After launching the Shadow Launcher and clicking ‘Start Now’ I get the following error:
    • Sorry, an Issue happened with the streaming service. Try to update graphics drivers on your device and disable Low Bandwidth Mode. (Error Code: R-300) [Then a big ‘Disable Low Bandwidth Mode’] which is disabled in my settings.

Actions Taken:

  • Updated my driver using `mhwd`.
    • Initially, `video-linux` version: 2018.05.04 was installed and enabled.
    • I have since disabled `video-linux` and installed and enabled `video-modesetting` version: 2020.01.13
  • Un-checked ‘Low Bandwitdh Mode’ in Launcher Settings.
  • Checked ‘Display Safe Mode’ in Launcher Settings as that got me further in the connection process when clicking ‘Start Now’.

Expected Results:

  • This XPS 9300 (2020) is a new 10th gen CPU/iGPU and should be able to handle the streaming of content easily.
  • Other people running Intel Graphics chips older than mine are not seeing issues with starting Shadow via the launcher even if they are running Linux (Ubuntu, Manjaro, or otherwise)
icon

Best answer by leithhobson 29 September 2020, 16:47

View original

1 reply

Hi

To copy some advice that was given to me:

R300 means no GPU decoder is available, make sure it's properly installed, configured. https://nicolasguilloux.github.io/blade-shadow-beta/setup

Note
the intel-media-va-driver-non-free

  

Reply