I have FINALLY discovered how to get correct, non buggy 5.1/7.1 Surround Sound!! :)


Userlevel 2
Badge

This issue has been driving me nuts for weeks. I love Shadow as a service, but it has been next to impossible to get correct channel surround sound to work till now.

The problem is that the native streaming that Shadow uses ONLY sends Stereo metadata to your Device/PC and there is no way of changing that. Even if you select 5.1 sound on your local PC, the surround speakers just replicate the front left and right speakers, even though it shows as a 5.1 input signal on your Receiver.

One solution given was to use a 5.1 or 7.1USB DAC and USB Forward the device to the Shadow VM. This seemed to work if the DAC had analog outputs, however, it was very buggy/glitchy and repeatedly cut out when I tried it. As for Dolby Digital Live/DTS Connect DACS, I couldn't get them to work at all.

The solution I have discovered is to set up Steam Remote Play just ONCE from your Shadow to your PC or Device (don't worry, you won't actually be using the Steam streaming service in its full form) and this should give you a new Sound Output option in the Sound Control Panel of your Shadow VM called 'Steam Streaming Speakers'. Select this as your Default Audio Output Device and configure your speakers as either 5.1 or 7.1. Another thing you can also do is change the Audio Sampling level in Properties to 32bit 48,000khz from 16bit 48,000khz (anything above 48k khz does not seem to work)

Now, as long as you have your local PC setup to have a 5.1 or 7.1 configuration, you should have full, non glitching surround sound with all the correct channels in place without any need to change any settings when you start up your Shadow.

I have yet to tell if the 'Use High Quality Audio' option in the Shadow Control Panel makes any difference to the Audio when using this method, but the change seems negligible if it does.

Hope this helps some of you, be good to know your feedback/opinions.


33 replies

Userlevel 6
Badge +5

Great work! Thank you!

Userlevel 4
Badge +3

Thank you so much for this! I’m going to validate it later today.

Userlevel 2
Badge

Thank you so much for this! I’m going to validate it later today.

Let me know how you get on. It works perfectly on my PC, yet I've discovered today that it doesn't work on my friends Shadow Ghost. :(

Userlevel 4
Badge +3

Let me know how you get on. It works perfectly on my PC, yet I've discovered today that it doesn't work on my friends Shadow Ghost. :(

Good find! I can confirm this works on my 7.1 system. I verified with the Tomb Raider benchmark I mentioned in https://forum.shadow.tech/compatibility-44/dolby-surround-dts-through-shadow-523?postid=3310#post3310 and it was great to have that be correct. Additionally, the Windows “test tones” can be verified to be coming out of the correct channels.

I have more information to contribute on this, but I don’t have the time to do that right now. I at least wanted to confirm that I got it working.

Thanks again for this discovery!

Userlevel 2
Badge

Let me know how you get on. It works perfectly on my PC, yet I've discovered today that it doesn't work on my friends Shadow Ghost. :(

Good find! I can confirm this works on my 7.1 system. I verified with the Tomb Raider benchmark I mentioned in https://forum.shadow.tech/compatibility-44/dolby-surround-dts-through-shadow-523?postid=3310#post3310 and it was great to have that be correct. Additionally, the Windows “test tones” can be verified to be coming out of the correct channels.

I have more information to contribute on this, but I don’t have the time to do that right now. I at least wanted to confirm that I got it working.

Thanks again for this discovery!

Cool. Glad it works for you too.

Yeah, if you've discovered anything further let us know. I have found today that the audio signal this produces works great with Dolby Digital Live or DTS Connect too which is handy for some people. 

Userlevel 4
Badge +3

Here are some additional notes; feedback is welcome!!

 

  • In order for the “Steam Streaming Speakers” playback device to be available, you need to stream a Steam game installed on your Shadow VM to another computer at least once.
  • To get to the new “Steam Streaming Speakers” playback device, you need to do one of these things:
    • Right-click the sound icon in the taskbar tray, hover over “Speaker setup,” then click “Advanced setup”
    • Right-click the sound icon in the taskbar tray, click “Sounds,” then click the “Playback” tab
  • Setting the “Steam Streaming Speakers” device as the default device, does not survive new Shadow sessions for me
  • You need to “Configure” the device to be in either 5.1 or 7.1 surround (to match your local configuration)
    • Performing the “Test” should work, and confirm sounds coming from the proper channels
  • If you are not hearing sounds coming from the speakers, try [single] clicking the sound icon in the taskbar tray, and click the volume slider repeatedly until you hear sound
    • If you don’t hear sounds from the tests, you likely won’t hear sound from your games!
  • The speaker setup (in the Shadow VM) still cannot be changed to use any form of spatial audio, and I’m not sure why (and why the surround configuration on the device above still works). I thought the speaker setup “had” to be configured for some form of spatial audio, but apparently that is not the case.
    • Perhaps this behavior changes when Dolby Access, or DTS Sound Unbound, gets installed?
  • Since (in my case) the default sound device doesn’t persist between Shadow sessions, you need to:
    • Change your sound output to the Steam Streaming Speakers (click the sound icon in the taskbar tray, click the carrot next to the device, and then click the “Steam Streaming Speakers”)
    • Click the sound icon again, and click the volume slider repeatedly until you hear sound (on my local system, I have to do this when switching between 7.1 / 5.1 / Dolby Atmos for Home Theater…perhaps it has something to do with my equipment)
Userlevel 2
Badge

Thanks for the notes and clarifying some points, some interesting things you’ve mentioned.

Wow, that is strange. When I load up my Shadow VM, it always has the Steam Stream Speakers selected as default with my 5.1 configuration. I wonder if Disabling the original Shadow Output would force it to use the Steam Streaming Speakers by default?

Windows Sonic and Dolby Atmos for Headphones are also available as options on my Shadow when using the Steam Streaming Speakers, but obviously it automatically sets my Speaker Configuration to Stereo when I select it.

I’m glad you are at least able to get Surround Sound working. Really interested to know what is not allowing you to have your setup as a default though and why you can’t access Windows Sonic. Will try and do some digging when I can.

 

Badge
  • Setting the “Steam Streaming Speakers” device as the default device, does not survive new Shadow sessions for me

You need to disable the existing “default” playback audio device (could be called “BladeShadow”, or something else depending on your own PC’s hardware).  This will allow the Steam Streaming Speakers device to remain the default.

If you connect to Shadow from multiple PCs/phones, etc, a new playback audio device might be created for each one and made the default, so you’d have to disable them, too.

Userlevel 4
Badge +3

Indeed it’s been a bit flaky for me, but hopefully just me. I played around with it a lot more last night, and sometimes the “Steam Stream Speakers” output does stick. Sometimes, though, the “Steam Stream Microphone” gets set as the default. I’ve noticed on my local PC, that the sound playback device sometimes changes to something I wasn’t using right after startup...perhaps it’s a Windows bug.

Also, sometimes I can’t get the sound to work out of the “Steam Stream Speakers” at all, even when the Shadow VM starts up with that as the default. I try the “volume clicking workaround” thing, but that doesn’t always fix it...but sometimes does! When I can’t get the sound to work at all, rebooting the Shadow VM usually does fix it. Again, maybe this weirdness is just happening for me - we need others to test this and comment on their experience.

I did try Dolby Access on the Shadow VM, and attempted to configure the “Dolby Atmos for home theater” with my local audio device selected (not the Steam speakers). It looked like it was going to work, but then the right setting didn’t appear in the “Spatial sound“ tab of the device, and the configuration wouldn’t save (I didn’t expect it to work anyway). I didn’t try to do anything with the “Windows Sonic for Headphones” one.

Still, that the “Steam Stream Speakers” works for true surround-sound is really cool. I was testing with that Tomb Raider benchmark, but then decided to start playing a new game with the volume cranked up...it sounded spectacular!

Userlevel 4
Badge +3
  • Setting the “Steam Streaming Speakers” device as the default device, does not survive new Shadow sessions for me

You need to disable the existing “default” playback audio device (could be called “BladeShadow”, or something else depending on your own PC’s hardware).  This will allow the Steam Streaming Speakers device to remain the default.

If you connect to Shadow from multiple PCs/phones, etc, a new playback audio device might be created for each one and made the default, so you’d have to disable them, too.


Ahh, got it - I will try this. Thanks!!

Userlevel 4
Badge +3

Regarding this trick not working on the Shadow Ghost - I assume that’s just a special Android device?

When I start a Shadow session from my Nvidia Shield TV, the audio is reported as PCM stereo, and never changes. Perhaps the Android client just doesn’t have any sort of surround-sound awareness programmed into it?

Userlevel 2
Badge

Aaah, ok. So there ARE some obvious limitations with this method then? Bummer. 

One thing I have noticed is that Windows Sonic certainly sounds/operates a lot better on Steam Streaming Speakers, which has made the Shadow experience on my Samsung phone a lot better. 

Oh well, it's a partial solution at least. Hopefully the Devs can use/learn from this how to offer pcm 5.1/7.1 across the board for all devices. 

Userlevel 1
Badge +2

 

Oh well, it's a partial solution at least. Hopefully the Devs can use/learn from this how to offer pcm 5.1/7.1 across the board for all devices. 


Shouldn’t be too difficult right? If you’re using an HDMI output, streaming Dolby 5.1 is easy, as with any other streaming app (e.g. Netflix). 
I don’t understand why the soundcard gets emulated however, why not use the standard HD Audio output, but this BladeShadow thing instead?

Userlevel 4
Badge +3

Shouldn’t be too difficult right? If you’re using an HDMI output, streaming Dolby 5.1 is easy, as with any other streaming app (e.g. Netflix). 

I don’t understand why the soundcard gets emulated however, why not use the standard HD Audio output, but this BladeShadow thing instead?

It’s likely because of the virtualization - there is no physical HDMI connection active on the Shadow VM’s GPU.

After weeks of investigation/tests/… to manage 7.1 sound your solution is working!!!

thank you very much.

i still have to reboot some Times but works well.

 

I just got Shadow Boost activated, and this method doesn’t appear to work for me.  I run my PC off HDMI via an AVR to get surround sound, but even when I stream from Steam remote play, I do not get the option on my Shadow to select Steam Speakers.  In fact, the odd thing is on my Shadow, all the sound becomes muted after starting the steam, but then in my Steam Remote Play Stream (via the Steam app on my local PC), I get full 5.1.  

 

I believe I am doing this correctly, I’m downloading a game on Steam on the Shadow, the using my local PC to launch a stream.  I went into Steam setting and selected 5.1 under advanced client setting on both the Shadow and local PC.

Userlevel 4
Badge +3

@Rich5741  your setup sounds just like mine - I have a Windows PC that is HDMI’d into an AVR, and can use the spatial audio and such with it.

 

So in terms of the Steam remote play, you just need to do that one time, so that the “Steam streaming speakers” device gets created on the Shadow VM. After that, it’s just a matter of configuring that new sound device, and selecting it for your output when using your Shadow VM from the PC that’s connected to your AVR. You don’t use the Steam remote play at all.

 

I tried to detail the steps in my post from June 12th above...are you following those steps, as well as @Corban1610 ‘s ?

Userlevel 4
Badge +3

It’s also important to follow @ZildyB ‘s advice of deleting the other sound devices. After doing that, it mostly “just works.” Every once in a while, the sound doesn’t work until rebooting the Shadow VM...but that seems to be rare. All of the settings seem to be persistent.

My only real desire now, is that this method worked for Android (Shield TV) clients (it doesn’t)… that would be the cat’s meow.

I did try disabling the BladeShadow sound device - when I do that, the sound doesn’t work at all, even over Steam Remote Play.  The odd thing is when I do access a game over Remote Play (Shadow hosting), I get 5.1, I just can’t get the Steam Speakers to show up.  Is there a special version of Steam I need to use?

Userlevel 4
Badge +3

I did try disabling the BladeShadow sound device - when I do that, the sound doesn’t work at all, even over Steam Remote Play.  The odd thing is when I do access a game over Remote Play (Shadow hosting), I get 5.1, I just can’t get the Steam Speakers to show up.  Is there a special version of Steam I need to use?


So if you simply connect to your Shadow VM normally (not via Remote Play), and look at the playback devices, you don’t see a “Stream streaming speakers” device?

 

I tried launching the stream from two different computers, one of which is a fresh Steam install.  I’ve also done it with and without disabling BladeShadow first.  I still don’t have those options, this is what mine looks like:

 

 

I am running the Sept 3 build of Steam on my Shadow.  I also have a Shadow running one of the Quadro rather than the 1080, maybe that’s part of the issue.

I also tried enabling then disabling high quality audio, no impact.

Userlevel 4
Badge +3

I am running the Sept 3 build of Steam on my Shadow.  I also have a Shadow running one of the Quadro rather than the 1080, maybe that’s part of the issue.

I also tried enabling then disabling high quality audio, no impact.

Weird that your Shadow isn’t getting that new playback device...I wonder if functionality has changed in newer versions of Steam. I’m going to do some tests on other computers to see what they do.

My Shadow (in LA data center) uses the Quadro P5000, so it doesn’t appear to be that.

Also, is the Windows version on your Shadow VM the 2004 or something older?

Weird that your Shadow isn’t getting that new playback device...I wonder if functionality has changed in newer versions of Steam. I’m going to do some tests on other computers to see what they do.

My Shadow (in LA data center) uses the Quadro P5000, so it doesn’t appear to be that.

Also, is the Windows version on your Shadow VM the 2004 or something older?

Inteersting

To confirm, you are using your computer to Stream a game from Steam, with Shadow as the host, and all that is needed is to start it and then exit.  I’ve tried starting it, playing a level first, as well as going into Shadow while the game is running or exiting first.

Notably, if I go into Shadow while the game is running, the volume controls show that things are muted, but no Steam Speakers.

Yes, I am on the 2004 version of Windows in the Shadow VM, running latest drivers via GeForce Experience.

Userlevel 4
Badge +3

To confirm, you are using your computer to Stream a game from Steam, with Shadow as the host, and all that is needed is to start it and then exit.  I’ve tried starting it, playing a level first, as well as going into Shadow while the game is running or exiting first.

Yes, you’re doing it exactly right. This is so strange.

I’m now on version 20H2, but was on 2004 when I set things up. I’m also using GFE and the latest drivers (452.06).

Reply