Is anyone successfully using a USB headset or found a way to use TeamSpeak?

  • 27 July 2020
  • 1 reply

I have a HyperX CloudII headset via USB but I have had a lot of trouble being able to use it with Shadow.

Without enabling/forwarding the HyperX USB device I get audio but can’t use my mic, to use my mic I have to enable the HyperX USB device to use the headset.


The problem is that as soon as I use TeamSpeak or play audio for awhile the audio cuts out. If I’m playing a game I can sometimes get TeamSpeak audio but no system or game audio and other times it doesn’t seem to have any audio at all. 


I have reinstalled and updated NVIDIA drivers, tried different bandwidth settings, tried low bandwidth mode, tried experimental high quality audio, updated the HyperX firmware and driver, reset computer and network equipment - nothing seems to work


I want to use this for gaming, but not being able to use a headset is a dealbreaker 


I am on Windows 10 hardwired to a gigabit connection


Best answer by Lily 28 July 2020, 09:30

View original

This topic has been closed for comments

1 reply

Userlevel 6
Badge +6

Dont use the usb peripherals function for your mic, use the mic tab. It should be able to just be connected and used.