Question

Is anyone using Logitech X52 HOTAS or WD My Passport 1TB USB HDD?


I am hoping to get them working on my Shadow.

 

My gear:

   Time of this report: 7/27/2020, 00:30:55
   Machine name: DESKTOP-5H6xxxx
   Machine Id: {06882856-0613-430B-A750-4A58B86Cxxxx}
   Operating System: Windows 10 Home 64-bit (10.0, Build 18363) (18362.19h1_release.190318-1202)
   Language: English (Regional Setting: English)
   System Manufacturer: Acer
   System Model: Aspire A515-43
   BIOS: V1.07 (type: UEFI)
   Processor: AMD Ryzen 3 3200U with Radeon Vega Mobile Gfx   (4 CPUs), ~2.6GHz
   Memory: 8192MB RAM
   Available OS Memory: 6082MB RAM
   Page File: 10053MB used, 3452MB available
   Windows Dir: C:\WINDOWS
   DirectX Version: DirectX 12
   DX Setup Parameters: Not found
   User DPI Setting: 288 DPI (300 percent)
   System DPI Setting: 288 DPI (300 percent)
   DWM DPI Scaling: UnKnown
   Miracast: Available, with HDCP
   Microsoft Graphics Hybrid: Not Supported
   DirectX Database Version: Unknown
   DxDiag Version: 10.00.18362.0387 64bit Unicode
 

USB:

 Razer DeathAdder Elite

 Razer Cynosa Chroma

 WD My Passport 0837 USB Device 1TB

 Logitech Unifying Receiver

 Logitech X52 HOTAS

 USB 3.0 3-Port Hub

 

Need any more info? 


19 replies

Userlevel 4
Badge +2

Enable usb over ip in the client and have the drivers install locally

 

local drives will be tricky as you need the upload speed to support it. For documents access its fine for most games it will be too slow

Thanks Gaigin for the reply.

 

I have been through all the steps with USB. Checked the box, waited on driver install, and nothing. Tried to check the boxes that show my peripherals, but they will not allow me to check them. Uninstalled and reinstalled drivers. Not getting anywhere.

 

The USB HDD and hotas setup are on usb 3.0 hub, connected to USB 3.0 port. Razer Cynosa and Razer Death Adder both are connected separate USB 2.0 ports.

 

I’m open to suggestion, and willing to entertain the ideas of others.

Userlevel 4
Badge +1

@Cold Warrior are you using the “official” Shadow client, or the beta?

Jim29er I believe that it is the “official” one. But where can I check to be sure?

Userlevel 4
Badge +1

Jim29er I believe that it is the “official” one. But where can I check to be sure?


If using the beta (or the alpha for that matter), it’ll be worded that way on the icon, as well as the title bar of the app.

I’d recommend trying the beta to see if that fixes your issues...it’s a “stable” client that is really more of a “release preview” than a beta. You can download the beta version(s) at the bottom of the “Shadow applications” section of your Account page.

@Jim29er 

Thanks for your replies. I’ll give that a shot and report my findings.

Userlevel 6
Badge +5

@Jim29er 

Thanks for your replies. I’ll give that a shot and report my findings.

What are you going to be using the drive for? 

@Jim29er 

Thanks for your replies. I’ll give that a shot and report my findings.

What are you going to be using the drive for? 

@Lily I was thinking that when I’m not playing a game on Shadow and need the space that I would copy the game directory to the ext drive. Then delete the directory on Shadow, and install another game. After I’m done with the second game, I’d copy it to the ext drive, and delete it on Shadow. Copy the first game back into Shadow, and play it.

 

I’m imagining that this is one of those great ideas that just won’t work. But you don’t know until you try. :)

Well I looked for the beta download. And looked……….And Looked. But I can’t seem to find it. Can someone point me in the right direction please.

Userlevel 4
Badge +1

Well I looked for the beta download. And looked……….And Looked. But I can’t seem to find it. Can someone point me in the right direction please.


Beta: https://update.shadow.tech/launcher/preprod/win/x64/ShadowBetaSetup.exe

Alpha: https://shdw.me/winalpha

Userlevel 4
Badge +1

@Lily I was thinking that when I’m not playing a game on Shadow and need the space that I would copy the game directory to the ext drive. Then delete the directory on Shadow, and install another game. After I’m done with the second game, I’d copy it to the ext drive, and delete it on Shadow. Copy the first game back into Shadow, and play it.

 

I’m imagining that this is one of those great ideas that just won’t work. But you don’t know until you try. :)

It’s a great idea, although will likely be far too slow to be feasible.

@Jim29er I have switched to the Beta from the standard version, but I am seeing the same results, Peripherals available = 4. Peripherals that will forward = 0. Anything else I should do?

Userlevel 4
Badge +1

@Jim29er I have switched to the Beta from the standard version, but I am seeing the same results, Peripherals available = 4. Peripherals that will forward = 0. Anything else I should do?


Hmm, are you following the steps listed in https://help.shadow.tech/hc/en-gb/articles/360017142874-How-to-Connect-a-USB-Device-to-Shadow ?

Does checking the box next to any of the USB devices in the Quick Menu work?

Yes those instructions are the ones I’m using. None of the boxes may be checked for peripherals in the quick menu.

Userlevel 6
Badge +5

@Jim29er 

Thanks for your replies. I’ll give that a shot and report my findings.

What are you going to be using the drive for? 

@Lily I was thinking that when I’m not playing a game on Shadow and need the space that I would copy the game directory to the ext drive. Then delete the directory on Shadow, and install another game. After I’m done with the second game, I’d copy it to the ext drive, and delete it on Shadow. Copy the first game back into Shadow, and play it.

 

I’m imagining that this is one of those great ideas that just won’t work. But you don’t know until you try. :)

Yeah sadly this would be wayyy too slow to actually be practical :( 

Userlevel 4
Badge +1

Yes those instructions are the ones I’m using. None of the boxes may be checked for peripherals in the quick menu.


Well, dang. I was under the impression that USB devices were forwarded more “blindly,” but it appears there are some limitations on which devices are supported that way. On macOS I was able to forward an XBO controller’s wireless dongle, which isn’t supported on macOS, but works when forwarded to the Shadow VM. That was quite magical to me :grinning:

Perhaps the next step is to open a support ticket, and see if they can give you any more insight? And then you can relay that to us here? :grinning:

Badge

Yes those instructions are the ones I’m using. None of the boxes may be checked for peripherals in the quick menu.

What is your ping? Ping can play a huge role when referring to the USB over IP function. Anything above 40ms UoverIP kinda kills itself because of the limited data transfer in the system. 

@Razorline 25-27 Ping here. 135-155 Mbps Down 15 Mbps up. Jitter is 2.08 to 6.63.

@Jim29er Just to cover the bases I’m going to install the Alpha and see what happens. If that’s a No-Go I’ll get with Support and see If they have a workable solution. 

 

More to follow.

Reply