Keep Shadow active while playing VR

  • 22 November 2020
  • 6 replies

When playing VR (pokerstars) with Virtual Desktop on my Oculus Quest 2, the shadows seems to time out after some time.  The game locks up, but audio chat remains working.  If I pull off my headset, or return to the VD environment, I can see the shadow inactivity warning, and the pokerstars window with (not responding) on the title bar.  seems like I can manage to keep the shadow from shutting down, but the game is unrecoverable.  If I try to use the “enter VR” button on VD, I get an error.


My workaround is to keep the mouse of the PC I stated shadow on nearby, and move it once in a while, but if I forget, i get locked up.  Any advice?  I was going to try an auto mouse mover, but then saw they are forbidden.

This topic has been closed for comments

6 replies

I purposely let this happen again so I could maybe track it down further.


The windows popup error I get when trying to switch back to VR via VD menu is a “missing hardware” error.  It appears that “the GPU” is being disconnected (hardware removed sound).  I suspect “the GPU” in this case is the Quest 2 display driver.

Userlevel 2
Badge +1

There’s a Quest input detection mechanism being tested in alpha, if you want to try.

Check on discord to know how to get the alpha version of your Shadow launcher.

Or wait a bit for this mechanism to go to beta / official versions.

Everyone says that the Shadow Alpha Launcher doesn’t work on the Quest 2 due to IPD settings.

Userlevel 2
Badge +1

I’m not talking about the alpha VR app. This one doesn’t use Virtual Desktop.

I’m talking about the Shadow launcher you use on your computer. Using it will make Virtual Desktop / Quest 2 inputs detectable by Shadow, then preventing the extinction to happen.

Oh, thank you for the clarification!  I will try it out.

So this worked all day yesterday.  Today when starting my Shadow, it did an update, and now it is crashing again after some time.