Question

Mac Big Sur update - mouse issue

  • 13 November 2020
  • 7 replies
  • 1213 views

Good day fellow shadowers) 

 

After totally reinstalling my Mac, and updating on Big Sur, I've got an issue with my mouse. After cmd+tab in any other application on Mac, and going back to shadow stream my mouse shuttering, stream is fine, latency fine, no packet loss, only mouse. Restart streaming from quick menu helps to fix that. 

I’m using shadow for about already 7 month, and everything was silky smooth.

Is it smth in Big Sur update? or maybe I need to disable smth in Mac settings, since it brand new and clear setup… thx in advance)


This topic has been closed for comments

7 replies

Hey there, this is a known issue that our developers are working on.  If you’re experiencing crashes as well, you can find a workaround here under the Mac tab but any updates regarding USBs itself will be linked in that article as well.

Badge

Thanks @Vash1k for posting this challenges.

Personally I have had latency and lag with my mice for some time know, read months, but now after the Apple mac OS update to “Big Sur” it has moved from usable - 25 % … to totally unusable, with rubber banding and lsgging.

Z

Hey there, this is a known issue that our developers are working on.  You can find a workaround here under the Mac tab.

I have a similar problem and your link above doesn’t help as that is a different issue with Mac stuck with an infinite boot. This is another problem where moving the mouse connected to a USB makes the games, connection lag. 

If I move my character in a game with my trackpad, it’s 100% fine with no stutters. 

Badge

Thanks for that post @LennsterNYC,

Just checked, and also moved some of my games around on my Shadow PC, in regards to my trackpad vs mice, of cause a USB connected mice also, your findings are replicated and Confirmed!

Then, what other ways do we, mac users, or more specific, macbook pro users, have as alternatives to connect a mice? … Bluetooth? like Apple’s own mice? cannot say that that one are any “gaming” mice or suitable for Star Citizen, World of Warships or any FPS games where speed and accuracy are needed …

 

Z

I have the exact same issue after upgraded to Big Sur from Mojave, and here are my observations:

  1. When using Magic Mouse, the cursor seems “better” without jumping that much;
  2. When using USB wired mouse, it’s a mess, and in CS GO, the view is locked and keep rotating when moving mouse, it looks like “Input Monitoring” was not enabled in settings for old macOS

I found a temporary solution, which works for me but MAY NOT BE APPLICABLE for everyone:

  1. Restart your mac, and make sure unselected “Reopen windows when logging back in”
  2. After restarted, DON’T OPEN ANY APP, run Shadow only
  3. It looks like for me, it was Chrome triggered the issue (sometimes running Chrome is fine, but open Youtube or any streaming website gets Shadow into the mouse issue)

 

Let me know if that helps.

Badge

Started up a “fresh” session, then started Shadow Client.

Result? did not do the trick … with my Shadow PC. 

Got verse after starting a game launcher and even more in “game”, from menu throughout match starting. So, for me, can’t use my Shadow for the intent of gaming from my Macbook Pro at all, after the Big Sur update. 

 

Z

Hey Folks,

I’m facing the exact same issue after upgrading my Macbook Pro (2017) to Big Sur.

None of the given workarounds work for me either ):

 ​​​​​