Major Audio glitching since this new update

  • 5 September 2020
  • 30 replies
  • 329 views

Userlevel 1

Since this latest client update I am getting constant audio stutter, within games and even when simply playing a video of YT. Nothing has changed on my end and it worked flawlessly before yesterdays update. States in the update note changes to the audio to use less CPU but whatever was done has now broken it completely. This is a standard laptop running Windows 10. I’ve tried restarting Shadow and my laptop and altering the bandwidth settings makes no difference, this needs looking into or simply reverting back to the previous client or at least make the pervious one available because as it stands the service isn’t fit for purpose, shame as Shadow is the best of the best for Cloud Services.


30 replies

Userlevel 4
Badge +3

Please state your Launcher and Client version numbers (listed at the bottom of the main window), and which client you’re using (alpha/beta/official).

Additionally, just because something might be broken for you, doesn’t necessarily mean it’s broken for others.

I have the same issue.

Userlevel 4
Badge +3

I have the same issue.

Yes, the same issue of not providing version numbers. :grinning:

These discussions are worthless without a frame of reference...

Launcher v4.16.6
Client v3.3.17

I haven’t the faintest idea which client it is, I assume it’s the official. 

I have the same issues aswell. Everything worked fine, before this garbage update. but now I got audio stutter every few seconds.

 

Launcher v4.16.6
Client v3.3.17

Userlevel 1

As requested:-

Launcher v4.16.6
Client v3.3.17

As stated everything was fine prior to the latest update.

Likewise - I just joined to see if I could find what my issue was and am not exactly happy but relieved that its not just me. 

 

Launcher v4.16.6
Client v3.3.17

Userlevel 4
Badge +3

I’m using the alpha client (Launcher 4.17.3 and Client 3.4.1) and not having problems, but will try the official client to see if I can reproduce.

Running the alpha client carries some risk, so is not for everyone. The beta client, however, is generally safe and has newer features. Are any of you willing to try the beta client and report back if the audio issue goes away?

I can, when I get the opportunity. It could be a few days.

I definetely wanne try the beta, if that is possible and see if the problem still exists.

Userlevel 1

Sure thing, would love to try the beta, client I looked for it earlier on your website.

Userlevel 4
Badge +3

I installed the official client, and verified the same launcher and client versions. After installing that client, a changelog appeared, and one of the items mentioned audio using less CPU. Anyway, I did experience severe audio dropouts (I like to test things via the benchmark in the Tomb Raider 2013 game), but only when “high quality audio” was enabled in the experimental settings. I normally have that off.

I had a similar experience when using the beta client a while back, and that’s when I stopped using the “high quality audio.”

Are you guys using that “high quality audio” setting? Also, are you using the “default” audio device, or using the “Steam streaming speakers” workaround to get surround-sound audio? I am using the latter, and it is glorious.

I’m going to go back to the alpha client, and see if there are differences with the “high quality audio” being enabled/disabled.

Edit/update: The audio dropouts remain (I’d say they are even worse) with the alpha client and the “high quality audio” enabled. With that disabled, everything is peachy.

Userlevel 4
Badge +3

BTW, the beta version can be downloaded from the “Shadow applications” section of your account portal, but I’ll put the Windows link here too:

https://update.shadow.tech/launcher/preprod/win/x64/ShadowBetaSetup.exe

Userlevel 1

Hi Jim,

Appreciate your update, I have just checked and I am not using the experimental settings for High End Audio, it’s just as default. I am using the default Windows device, I’ve not heard of this Steam Streaming Speakers, I assume that’s a chance of the audio device in Windows itself on the host as oppose to any settings with Shadow or am I wrong? Thanks for the link to the beta, will uninstall the official client and try the beta and let you know the reseults, as I said what is strange is there were no issues till the update this week which specifically mentions the change the audio demand on the CPU, it appears to have done the opposite but I will test the beta version now and report back.

Userlevel 1

Hi again Jim,

Downloaded and installed the beta but not tested it yet, but I think I know what the problem is.

The updated client has change the Streaming optimization back to UDP over TCP to prefer speed instead of reliabilty. The default on the beta client Launcher v4.16.6 Client v3.320 is TCP which makes sense as UDP can be very unpredictable. 

Might be worth you all checking if this is the case for others that have reported the issues too and change to back to TCP.

Userlevel 1

Hi again Jim,

I can confirm it is the streaming protocol change that is causing the issues.

I installed the Beta it defaults to TCP - prefer reliability, seemed to work OK, changed the protocol to UDP - prefer speed and it exhibited exactly the same issue as the official client. I uninstalled the beta and reinstalled the official client, that defaults to UDP, prefer speed, changed to back to TCP - reliability and it works fine. So either the changes that were made to the audio pipeline to use less resources have affected the UDP performance of the new client is simply defaulting the UDP which it is and maybe previously would have defaulted to prefer reliability as the Beta client does.

Hope that helps :)

ShrikeX

Badge

I can confirm what ShrikeX said. I changed my optimize streaming settings (official client) back to reliability and it works as it did before the update.

Userlevel 4
Badge +3

@ShrikeX thank you for those observations! I’d think that the “prefer speed” (UDP) would be better for most people, but indeed I have heard of problems being solved by switching to TCP. I wonder if the UDP problems are exacerbated when network jitter is a factor...just a thought.

Mine is using “prefer speed” (UDP). I wonder if the “high quality audio” dropouts would go away under TCP...another task to add to the list.

Regarding the “Steam streaming speakers” workaround - that’s a change on the Shadow VM side, so that real surround-sound is carried through to your local system. If your local system isn’t using surround-sound, then it won’t have a benefit. If you’re interested, the article is at:

 

Userlevel 1

Hi Jim,

Thanks for the link, will look into that. I have tested the TCP connection - prefer reliability works better, well there’s no audio glitching, but there are some issues with screen redraw etc. I suspect the changes made to “optimize” the usage of audio on the CPU have also had back-end changes and they are being experienced by people. Changing back to prefer reliability over TCP is a solution but isn’t ideal if the preferred service delivery would be over UDP, those issues need reporting back to the devs and dealing with :)

Userlevel 4
Badge +3

So I switched my alpha client to “prefer reliability” (TCP), and it mentions in the description that it’s for correcting “occasional audio and cursor stuttering.” The “high quality audio” does indeed then work without drops.

I suppose one of us could engage Blade support with this to see if they are aware/pick their brain… It does seem like a bad thing if a client update reverts back to UDP after being willfully configured for TCP, but perhaps they also thought that some of those audio issues might have gone away with their updated client, and y’all were the babies thrown out with the bathwater.

Userlevel 1

Appears what was the beta yesterday has now gone live as the new update is for the client to v3.3320, checking the streaming settings and this has left the setting to TCP “prefer reliability”. Interesting :) 

BTW Jim, what exactly is “High Quality Audio” - how does it change? Compression, Bit rate? there’s no info on what it does.

Userlevel 1

Issues appear to be getting worse, almost to a point where Shadow right now isn’t useable for some, not sure if this is network latency, issues with a specific datacenter, think I am connected via Paris.

With UDP set for “Prefer Speed” there is major audio break-up, not too sure it’s actually related to the audio itself, it does appear to be a latency issue or something.

With TCP set for “prefer reliability” there’s major video issues, complete screen break-up and redraw issues, this is as per the updated client v3.3320, was also apparent on v3.3317

None of these issues were occurring prior to this Update notification announcing the changes. I don’t know what the build was prior to the update this week but with the current state it’s a mess and needs to be addressed.

Userlevel 4
Badge +3

BTW Jim, what exactly is “High Quality Audio” - how does it change? Compression, Bit rate? there’s no info on what it does.

 

Just tried the beta. No packet loss and no audio stuttering. High quality works like a dreams on beta, like it did before on the official version, before this update came out on the official version.

Userlevel 1

Hmmm what version are you running now Ameleke as the official client was updated from the beta today, unless there is another new beta??

Also you using prefer speed or reliability?

Reply