Solved

mouse issue - toggle "locked mouse"

  • 9 October 2020
  • 9 replies
  • 624 views

Badge

Hi everyone,

 

resently i got the problem that i always have to switch the mouse lock (win+alt+m) to use my mouse properly.

 

When I play a game, I cannot turn my character completely if I have not locked the mouse to the shadow. However, when I switch to the desktop, I cannot see my mouse until I unfix my mouse again. That was not the case before. Has anything been changed and if so, can you somehow undo it? This problem does not exist, if the game hasn’t been started yet. (e.g. Satisfactory)

I play on windows.

 

Kind regards

icon

Best answer by Lily 14 October 2020, 12:06

View original

9 replies

Userlevel 6
Badge +5

Well yes, you have to lock your mouse in order to be able to fully use it in a game, especially turning around 360. But it should not disappear, have you tried the beta/alpha client? 
You can find the beta client on your Shadow account page. 

I want to revive this topic as I recently started having a very similar issues when using the moue/keyboard for gaming. I’ve mainly noticed it in witcher 1. When I go into a sub screen, like the Journal, Map, Inventory screens etc I have to UNLOCK the moue to navigate those screens. but when I go back to the main game screen to run around the world I need to LOCK my mouse again to move around. Usually the first few times I go into those sub screens it works fine but then after about the 6-7th time I have to start locking/unlocking the mouse. I have a macbook pro. But like I said it only recently started doing this within the last week. The only thing that has changed is that I now have my macbook pro hooked up to an HP 27 inch monitor. My screen cracked on I can’t really test it on the macbook to see if my eternal screen is causing the issues

 

Regards,

j.

I want to revive this topic as I recently started having a very similar issues when using the moue/keyboard for gaming. I’ve mainly noticed it in witcher 1. When I go into a sub screen, like the Journal, Map, Inventory screens etc I have to UNLOCK the moue to navigate those screens. but when I go back to the main game screen to run around the world I need to LOCK my mouse again to move around. Usually the first few times I go into those sub screens it works fine but then after about the 6-7th time I have to start locking/unlocking the mouse. I have a macbook pro. But like I said it only recently started doing this within the last week. The only thing that has changed is that I now have my macbook pro hooked up to an HP 27 inch monitor. My screen cracked on I can’t really test it on the macbook to see if my eternal screen is causing the issues

 

Regards,

j.

Exactly the same problem in my case.

 

Is there any proper solution for this issue ?

 

KR 

J

Well yes, you have to lock your mouse in order to be able to fully use it in a game, especially turning around 360. But it should not disappear, have you tried the beta/alpha client? 
You can find the beta client on your Shadow account page. 

tried it but doesnt solve the problem…

 

KR

J

This issue still persists and it’s been one month since it started happening. I hate to say it but… I have switched over to GeoForce now for the time being . it does it in all games for me now. any time there is a sub menu I have to “unlock” mouse. navigate the submenu, then “lock mouse once I am be in the main game. it happened most recently in COD Cold war. like when I want to change class. I know it seems very minor but, OMG it totally interrupts the flow of the game. Moreso in games that are very heavy on submenus (aka, witcher series where you have journal, map, bag etc)

 

I hope this gets fixed soon, because i haven’t really used shadowtech since a few days after this started happening

Badge

Hi, for me the sollution has been to switch from UDP to TCP in the settings. Maybe give it a shot.

 

Good luck!

Hi, for me the sollution has been to switch from UDP to TCP in the settings. Maybe give it a shot.

 

Good luck!

 

didn´t work in my case because the stream was very ugly in this setting - so that´s not an option...

I will add a quick problem i had that this solved. On the recent alpha, when using multi screen, games were extremely sensitive or wouldn't find the mouse at all (Valheim). Locking the cursor is the only way I have gotten it to work.

Same Probleme here - every Game that has no ‘Controller Cursor Mouse steering emulation’ build in causes Problems.
Example:
AC Origins when Shadow Cursor is Locked -> no Problem in Game you can use the ingame Cursor instead → fine Gaming

AC Odysee when Shadow Cursor is Locked -> the in Game Cursor is locked too - you allways have to unlock if you want to move to inside Inventory ingame items menus etc. -> before leaving back out of Inventory you need to Lock the Cursor again otherwise the Mouse moves to second screen on my native Computer (I don’t mean the imo not useless second Screen feature from Blade).

Thats an issue that keeps me using Shadow for some Games - It’s anoying allways manualy lock and unlocking the cursor and in my mind older clients did not have that issue. Maybe the automatic lock unlock feature that once existed is broken not anymore existent or it has other reasons.

Another strange behavior - when Shadow is freshly startet - everything is fine - Cursor stays on Shadow System as it should. Ingame or Windows Desktop - everything works.

After a while - maybe 3 to 5 Minutes in Game the Cursor locks automaticly and the above described issues come in -> No more Cursor moving - unlock cursor -> Mouse becomes able to leave Shadow Desktop to my own native second Screen.
Starting Shadow Blade in Fullscreen or Window does not depend - same behaviour.
Deactivating native Second Screen on Home PC helps a bit - Cursor can be unlocked but that comes with the 360degree issue so you have to Lock the Cursor again to have a 360 movement...

 

Please Shadow Team try to fix it

 

Reply