PS4 DUALSHOCK 4 Controller Bluetooth Issues

  • 13 September 2020
  • 11 replies

Since I activated my Shadow, I haven’t been able to use my Dualshock 4 controller via Bluetooth, it has only worked with a wired USB connection. The controller is recognized within Shadow when it’s connected via Bluetooth, but it just doesn’t do anything. No inputs from the controller work. Has anyone else on Mac had this problem? Here’s all my specs:

  • Mac High Sierra 10.13.6

  • Official Boost Shadow Client Version

  • 2.7 GHz Intel Core i5

  • AMD Radeon HD 6770M 512 MB

  • California Datacenter

  • 217.82 Mb/s download speed, 6.86 Mb/s upload speed, 64.85 ping, 146.08 jitter

  • Description: PS4 Dualshock 4 controller not functioning at all over Bluetooth


  • Date since first incident: 9/5/2020

  • Did you take any action(s) which could have created this problem? If so, what?

    • No

  • Do you recall any action(s) you took after it happened?

    • Yes, several troubleshoots of bluetooth connectivity and USB connectivity

  • Do you use a VPN and/or antivirus?

    • No VPN, yes antivirus

  • Please provide a screenshot of your shadow stats (Alt+Win+O). Also make sure it captures a timeframe when the issue has happened.


11 replies

Userlevel 5
Badge +6

Hi @mjlangla ,


Have you considered this for your ps4 controller? 

I would really not like to have to purchase something to make this work, especially something at that price. The controller connects to my computer via Bluetooth just fine, it’s the connection to Shadow that seems to be the problem. Thank you for the suggestion though.

Userlevel 5
Badge +4

@mjlangla your controller functions normally (when connected via Bluetooth) outside of Shadow, correct? You can confirm that via the site using Chrome.

I looked over that Amazon link for the USB dongle, and it’s implied that’s just a glorified BT adapter...if that’s the case, it’s not going to solve anything.

I don’t have a Dualshock 4 controller, otherwise I’d test things on Catalina.

@Jim29er yes it does, just tested it on that site and everything seems to be functioning properly on my end. That’s a great tool, thanks for sharing that.

Userlevel 5
Badge +4

So I asked about this on the Discord server, and Alex chimed in with the below. I haven’t used it myself, but perhaps something to try?


Alex^The good test is to download on local mac then check if controller works. Then open (show package contents) and look for gamecontrollerdb.txt and check if (first component of the gamepad app mapping) is already present and valid. Or add your own ;)


Userlevel 5
Badge +4

Also, do you have the “DS4Windows” installed on the Shadow VM? I don’t know if that’s a requirement either, but I’ve read people talking about it.

oh awesome, thanks for doing that! I’ll try that out and let you know how it goes

Okay, so I tested the controller with the gamepad tool, all looks good there. Found the gamecontrollerdb.txt file, did a search for ‘’, nothing to be found. Where would I add that? Sorry if that’s a silly question haha, I have very little experience with this amount of troubleshooting


I also added DS4Windows on the VM, unfortunately to no avail.

Userlevel 5
Badge +4

I’m going through this now as well...I haven’t installed the gamepad tool yet, but rather was looking for the gamecontrollerdb.txt file first (I didn’t see your update until now). For others who might see this later, do a Finder search after opening the .app contents:


Userlevel 5
Badge +4

Okay, here’s the tool’s output for my XBO S controller:

Gamepad Tool output

So I clicked “Copy Mapping String” which provides this:

Mapping string for "Xbox Wireless Controller" is

030000005e040000fd02000003090000,Xbox Wireless Controller,a:b0,b:b1,back:b16,dpdown:h0.4,dpleft:h0.8,dpright:h0.2,dpup:h0.1,guide:b15,leftshoulder:b6,leftstick:b13,lefttrigger:a5,leftx:a0,lefty:a1,rightshoulder:b7,rightstick:b14,righttrigger:a4,rightx:a2,righty:a3,start:b11,x:b3,y:b4,platform:Mac OS X,

And if you search the gamecontrollerdb.txt file, you’ll find the entry in there. So if the entry for your controller is not there...paste it in the # Mac OS X section, save, and launch the Shadow app.

I highlighted the pertinent in red above...note there are no quote marks in the text file, so don’t paste those in.


I’ve the same issue, with same config (mac on high sierra). I can use my PS4 controller via USB only, not Bluetooth.

the controller appears well on Shadow (in the controller part) in both cases but it only works on steam when plugged in USB. Have you solved your problem ?