Question

Puppy Linux Error code: R-0x7F on Start Now

  • 18 July 2020
  • 8 replies
  • 914 views

Hey guys, 
i3 2015, 4GB ram Asus 15’ laptop, Puppy Linux on 64GB USB + Internal Hard Drive.
About three - four weeks ago I started getting the ‘Error code: R-0x7F’ when hitting ‘Start Now’.
I figure a missing dependency, but the libs are there, just not being read right(?). Running the appimage from terminal with --no-sandbox and here’s the readout.
root# /mnt/home/Shadow.AppImage --no-sandbox /tmp/.mount_ShadowHAsgtO/shadow: /lib/libdbus-1.so.3: no version information available (required by /tmp/.mount_ShadowHAsgtO/shadow) /initrd/mnt/tmpfs/tmp/.mount_ShadowHAsgtO/shadow: /lib/libdbus-1.so.3: no version information available (required by /initrd/mnt/tmpfs/tmp/.mount_ShadowHAsgtO/shadow) Fontconfig warning: "/etc/fonts/fonts.conf", line 86: unknown element "blank" Checking for update Update for version 5.0.638 is not available (latest version: 5.0.638, downgrade is disallowed). This error originated either by throwing inside of an async function without a catch block, or by rejecting a promise which was not handled with .catch(). The promise rejected with the reason: Error: Unknown or unsupported transport 'disabled' for address 'disabled:'

As one could figure, being able to run from the ‘lowest’ resources is definitely what I’m after.


8 replies

Well, i don’t know about a solution but i ran into the exact same error on my system.

I’m using Fedora 32.

I tried however on an ubuntu machine (a second PC i have) there it’s working (at least the desktop is, i haven’t tried gaming yet).

I was under the impression that using an AppImage would make the launcher platform independent (or at least distro independent), i guess not.

 

Regards

J

Hi,

 

I had the same problem.

For me it was enough to install the package “libva-glx2”.

As it is here under Ubuntu
I hope I could help you and others.

 

Sorry for my bad english.

 

Hi,
I had the same problem and after installing ‘libva-glx2’ now I can login but I have the screen black or red and the icons are flashing every often. I try to change the Resolution but still happening, is been a week already since that update before was working great.

I hope Shadow Team fix that. I love the account and I am sure they will find the solution soon.

Regards,
 

Based on what I’m seeing here (I installed libva-glx2) if you get this error ….you just have to give up and cancel the service as there is no solution?

Userlevel 5
Badge +4

Hey guys, thanks for reaching out to us!  Out of curiosity, can you guys try using this command line: "sudo apt install gconf2 libgles2-mesa libubsan0 libuv1 libva-glx2" 

 

We’ve heard that this has worked for some of our community members and want to see if it works for you guys too!

 

@Jayson @Jonas_Bos @edbN7XR9 @Rootes @Zara (pinging you guys just in case :) )

I tried “sudo apt install gconf2 libgles2-mesa libubsan0 libuv1 libva-glx2” and the command completed. I restarted and got the same error. I wish it just came as a deb or something as this appimage is utterly …...well it just doesn’t work at all for me.

 

Userlevel 2
Badge +1

Woohoo Linux is broken. I used linux because I like linux and if I need Windows I could use shadow. I guess I'll have to back to crappy windows. Yay. It's like going back to an old gf cause you're desperate. 😖

I have been getting the same R-0x7F error for about a week now. I installed the packages suggested by @BrittaneyFromShadow and that fixed it for me:

https://forum.shadow.tech/technical-assistance-7/puppy-linux-error-code-r-0x7f-on-start-now-1016?postid=7039#post7039

 

My System Info:

vainfo

libva info: VA-API version 1.7.0
libva info: Trying to open /usr/lib/x86_64-linux-gnu/dri/nvidia_drv_video.so
libva info: Found init function __vaDriverInit_1_1
libva info: va_openDriver() returns 0
vainfo: VA-API version: 1.7 (libva 2.6.0)
vainfo: Driver version: Splitted-Desktop Systems VDPAU backend for VA-API (arekinath) - 0.7.4
vainfo: Supported profile and entrypoints
VAProfileMPEG2Simple            :    VAEntrypointVLD
VAProfileMPEG2Main              :    VAEntrypointVLD
VAProfileMPEG4Simple            :    VAEntrypointVLD
VAProfileMPEG4AdvancedSimple    :    VAEntrypointVLD
<unknown profile>               :    VAEntrypointVLD
VAProfileH264Main               :    VAEntrypointVLD
VAProfileH264High               :    VAEntrypointVLD
VAProfileVC1Simple              :    VAEntrypointVLD
VAProfileVC1Main                :    VAEntrypointVLD
VAProfileVC1Advanced            :    VAEntrypointVLD

screenfetch

OS: Linuxmint 20 ulyana
Kernel: x86_64 Linux 5.4.0-48-generic
Uptime: 1d 19h 58m
Packages: 2614
Shell: bash 5.0.17
Resolution: 3120x1920
DE: Cinnamon 4.6.7
WM: Muffin
WM Theme: Mint-Y-Dark (Mint-Y)
GTK Theme: Mint-Y [GTK2/3]
Icon Theme: Mint-Y
Font: Ubuntu 10
Disk: 2.7T / 4.2T (64%)
CPU: Intel Core i5-6400 @ 4x 3.3GHz [30.0°C]
GPU: GeForce GTX 1060 6GB
RAM: 7032MiB / 15976MiB                                   

 

Reply