Question

R-0x4 Error. (Shadow needs compoents it does not posses)


Userlevel 5
Badge +5

R-0x4

My shadow client keeps showing this error what can I do to fix it?

R-0x4 is an error that appears when your shadow client is missing underling operating system components. This particialr error affects Linux and Windows Users. 

For Linux you will need to download and install vaapi portions. For Windows you will need to install Dot Net 3.5 Redistribute. 

Still having trouble? Try these steps to get your shadow client working: 

1. Uninstall Shadow

2. Go to the your %appdata% folder (Windows search '%appdata%') and delete all 'Shadow'-related folders 3. Delete the folder C://Users/username/.shadow

4. Restart your computer

5. Download and install Shadow again at https://account.shadow.tech/apps (choose Applications on the left)


10 replies

Hello Gelgoog,

 

I'm sorry to dig up this topic, but I have scrupulously followed all the steps in your post, and yet the problem still persists.

I also tried to contact the technical service, who send me your solution.

However, there must be another location where Shadow files are installed.

Because just after my reinstallation of the launcher, I am automatically recognized without entering my credentials.

Do you have any leads? Because I have no news from the technical service.

 

Userlevel 5
Badge +5

@Suns 

Could you clarify what os you have? along with all the other information I would need to see if I can help further… (see how to ask for help) 

 

In order for our mods and community to provide you with quick and quality assistance, please copy & paste the template below in your original post and provide the necessary information.

Not using the template may result in having your topic removed

+++

  • Application type (Windows/Mac/Mobile/etc.)

  • Shadow Client Version (Official/Beta/Alpha)

  • Local device CPU

  • Local device GPU

  • Datacenter location (check status.shadow.tech)

  • Connection speed (Datacenter speed tests EU: Paris | AMS or US: CA | TX |CH | NY)

  • Description of issue

Other:

  • Date when problem appeared.

  • Did you take any action(s) which could have created this problem? If so, what?

  • Do you recall any action(s) you took after it happened?

  • Do you use a VPN and/or antivirus?

  • Please provide a screenshot of your shadow stats (Alt+Win+O). Also make sure it captures a timeframe when the issue has happened.

 

+++

  • Windows

  • Official

  • Intel i7-3540M

  • AMD Radeon HD 7570M

  • Santa Clara

  • 22.35mb/s download/5mb/s upload

  • I have been using shadow for around 6 months now and have had no troubles until today. All day today I have been attempting to start my shadow streaming and every time I get an R-0x4 error. It says that an unknown issue happened and that I should restart my shadow application.

Other:

  • 3/7/2021

  • No

  • I have relaunched my application multiple times, I have reinstalled shadow twice, and I have done a disk check to check for corrupted files and it still will not work. 

  • I use Malwarebytes, but it has been on before and never caused problems



 

Userlevel 5
Badge +3

Hey @Sweden , 
You can try uninstalling Malwarebytes and make sure your firewall is not blocking anything. A recent update may cause some issues. If that doesn’t work and nobody has more suggestions you should contact support since that would probably be faster than waiting for a useful response here. Make sure to include everything in your current post in your support request as this contains useful information.
Have a nice day!

Hello Gelgoog,

 

I'm sorry to dig up this topic, but I have scrupulously followed all the steps in your post, and yet the problem still persists.

I also tried to contact the technical service, who send me your solution.

However, there must be another location where Shadow files are installed.

Because just after my reinstallation of the launcher, I am automatically recognized without entering my credentials.

Do you have any leads? Because I have no news from the technical service.

 

Hello there, I have the same issue… Did you fix yours or it still remains?

I really need help, started having this issue just after I formatted my computer…

Userlevel 5
Badge +5

@Behroz It 

Did you ensure that your newly formatted pc has all updates and is on the latest version of windows before you installed shadow client?

Badge

I can’t launch shadow. It worked perfectly fine yesterday.

 

 

Image: https://imgur.com/a/cMp01B0

Hello everyone , 

For those who ad the issue R-0x4 Error. please ensure your PC is not in mode “Save Power” in power settings this is the path in french and english : 

open Panneau de configuration\Tous les Panneaux de configuration\Options d’alimentation

open Control Panel, select System and Security > Power Options, then choose a Balanced power plan or .

I had this issue for long time and realise it by myself and want to share with all of you out there i hope this will help you all . 

I got the Unkown error R-0x4.

HOW I RESOLVED IT:

After I read post from BadBunnie, in this forum.

 

Followed Gelgoog Post above:

 

1/   Uninstall Shadow Launcher,
2/   Remove SHADOW related folders in %APPDATA%%
3/   Remove .shadowtech folder in USER folder

ALSO, Things to check:

 

1/   Make sure .NET framework 3.5 or higher installed.
2/   Also may help to have latest C++ distribution (now 2022) installed

3/   Check Power Option  per Adel post sbove

4/   RESTART PC, reinstall Launcher & try again.

 

IF still have same issue:

 

Check if you have 2 graphic cards installed,  1 integrated and 1 dedicated graphic card.

If you DISABLED integrated card by using Windows DEVICE MANAGER in Control Panel, then you have to ENABLE it and reboot pc & try shadow launcher again.

 

If its a PC, you can use BIOS to disable Integrated Graphic Card (not in Windows Device Manager).

If laptop, some dont have option to DISABLE in BIOS (my case).

After enable it should work, and let you access your Shadow PC.


 

Reply