Solved

RC-105 error. Controller no longer working

  • 13 June 2020
  • 3 replies
  • 1518 views

Badge +1

Shadow boost. My DS4 worked fine for a month until a few days ago and now I get a RC-105 error anytime I plug in my controller via USB. Tried different controllers, cables, resinstalling drivers, etc. Nothing has worked so far.

icon

Best answer by Chibi Octi 23 June 2020, 10:16

View original

This topic has been closed for comments

3 replies

Badge

I’m having similar issues too, the issue only started for me today Saturday 20th June. I’m using the Windows 10 client on my GPD Win 2, tried the built in controller, 8bitdo N30 Pro 2 and an xbox One controller with bluetooth wired and xbox usb adapter, but nothing works. I’ve even updated Windows on Shadow, tried both beta and stable Shadow Windows client, but still no luck.

 

These are the errors that I receive.

‘Sorry an issue has happened with the controller services’ Error code: SC-104

‘Sorry an issue has happened connecting your controller’ Error code: RC-105

Badge

Hey @Tekky,

I received this guidance from the Shadow support desk to solve the issue. Unfortunately, I’m unable to try this solution out because I factory reset my Shadow.

 

First, you can simply reboot your Shadow.

Then you can try it out by logging into Shadow from another version of your app.

For example, if you were on the official Windows app version, try the Beta version.

Link to download the applications here: https://account.shadow.tech/apps

Finally, this manipulation also helped some of our users:

1. Unplug your controller
2. On your Shadow, click on the Windows button and type 'cmd'
3. Right click on "Command Prompt" and choose "Run as administrator";
4. In the window that opens: copy and paste the following text: MsiExec.exe / x {37FD52BF-1242-4404-82A3-0ABC2F2ECDBB}
5. Press "Enter"
6. Restart Windows on Shadow

After restarting, wait at least 5 minutes before trying to reconnect your controller. This will give Shadow services time to update.

Userlevel 6
Badge +6

You should also try a fix that the bot on the website has. l