Solved

Shadow causes External 4k monitor to flicker and tear


Badge
  • OS = Windows

  • Shadow Client Version = Beta and latest

  • Local device CPU = i7 1065G7

  • Local device GPU = GTX1650 Max Q and Intel Iris Plus

  • Datacenter location = Paris

  • Connection speed = 28M down, 8M up

Hello!

I have an external 4k monitor (LG 27UL850-W) connected to my laptop (Razer Blade Stealth GTX) via USB-C Displayport and as soon as the shadow stream is on the external monitor, the monitor flickers and tears. This happens when the shadow stream is in windowed and in full screen mode. The display of the laptop remains normal with no issues so I don’t believe it is the Graphics driver. I also spoke to Razer support and they believe the same (although they would ;-)).

I can play games on the laptop through the external screen fine as well, it is only when the shadow desktop stream touches it that I have the problem. I have tried both the latest stable and Beta versions of the app.

Any help or suggestions are greatly appreciated!

Thanks in advance.

icon

Best answer by d0a4p 10 August 2020, 20:44

View original

11 replies

Userlevel 5
Badge +5

Hi d0a4p,

 

Do you know if gsync is enabled on your monitor? If so try disabling it and re-launching the shadow stream.

Badge

Thanks for that. However I have checked the FreeSync settings on the monitor and they are off. I think that FreeSync is only compatible with AMD cards as well isn’t it? 

It is weird, it happens as soon as the stream opens to the desktop so there isn’t anything really taxing going on.

Userlevel 5
Badge +1

FreeSync also works with Nvidia cards.

What about the monitor refresh rate, is it the same as setup in Shadow?

Badge

Ah ok. I have just had a little google myself and as it is a laptop all the displays go via the intel gpu so FreeSync/G-Sync can’t be used. So at least that rules that out!

I have checked that the refresh rate matches both (60hz) and also tried setting the Shadow stream to 59hz just in case and that doesn’t make a difference.

One weird thing is that when in windowed mode, if I move the window to have even 1 line of pixels off the bottom of my external display it stops. 

It is just a very weird symptom!

I hope that all makes sense and thanks for the help.

Userlevel 6
Badge +5

Try only having the 4k monitor enabled when using Shadow, so turn off the laptop screen.

Badge

Yeah, unfortunately that was one of the first things I tried (along with reducing the Res to 1080) and didn't work. Sorry, I forgot to add that to the OP. 

Thanks though. 

Userlevel 6
Badge +5

Yeah, unfortunately that was one of the first things I tried (along with reducing the Res to 1080) and didn't work. Sorry, I forgot to add that to the OP. 

Thanks though. 

Have you tried running Shadow off the integrated graphics? 

Badge

Yes, I have just double checked again (tried so many things, I forgot exactly what I have done!) and it does it with both gpu’s, confirmed by seeing the process using gpu1 or gpu0 in task manager. 

Looks like I may have to accept it is not compatible with the setup I have.

Badge

Think I have fixed it!!! Seems that is WAS a monitor sync issue. But not AMD, or G but intel AdaptiveSync. Didn't even realise they had it but stumbled on a post that alluded to it and they do. Turned it off and the problem appears to have stopped. 

Fingers crossed that is it and hopefully it'll help someone with this problem in the future. 

Thanks all for your help. 

Userlevel 6
Badge +5

Think I have fixed it!!! Seems that is WAS a monitor sync issue. But not AMD, or G but intel AdaptiveSync. Didn't even realise they had it but stumbled on a post that alluded to it and they do. Turned it off and the problem appears to have stopped. 

Fingers crossed that is it and hopefully it'll help someone with this problem in the future. 

Thanks all for your help. 

Thats great to hear and Im glad to know that its fixed!

Userlevel 1
Badge

future reference, and im sorry if its not too relative but an issue with samsung 4k tv, i was having tear issues, and really unsteady lag. the only way i was about to fix it properly, was on my tv, hit smart view, and the hdmi connection that says PC, change it to game console and it will automatically adjust the settings to it.

Reply