Solved

Shadow video stream won't start on Ubuntu 21.10 due to dependency on libldap==2.4

  • 31 October 2021
  • 11 replies
  • 241 views

Badge

Hi,

 

I’m trying to get shadow running on Ubuntu 21.10 (I need linux kernel 5.12+).

Unfortunately, when starting the stream I’m getting a R-0x7F error code.

By tracing syscalls from the AppImage, I can tell that both libldap_r-2.4.so.2 and liblber-2.4.so.2 are missing on my system as Ubuntu 21.10 ships with openldap 2.5.

 

I tried to add symbolic links to the 2.5 version of libldap shared objects available on my system, which works, but now I’m getting a R-1 error indicating that a shadow app “is already running on my system” (it’s not clear to me what libdap is doing when launching the video stream :thinking: )

 

Do you know any work around the issue ?

Does the dev team plan to support Ubuntu 21.10 ?

 

Regards,

Nicolas

icon

Best answer by lavrenti 17 November 2021, 18:52

View original

11 replies

Userlevel 5
Badge +3

Cheers @nicocti 
You might find your answer here: https://nicolasguilloux.github.io/blade-shadow-beta/setup.

Hello,

I have exactly the same problem… And no, the answer is not on the provided link… :frowning2:

It is clear that the AppImage version of Shadow is not compatible with Ubuntu 21.10… It was working with Ubuntu 21.04.

It would be good to have a new AppImage for this ubuntu version.

Thanks for your help
Laurent

Userlevel 5
Badge +3

Ah there was an update :) Was still on 21.04 mindset, sorry.

Can confirm this issue on Kubuntu 21.10

 

Installing

 

intel-media-va-driver-non-free
vainfo
libva-glx2

 

via apt did not help

Hello,

I found through the Discord channel that it is possible to fix this problem, by extracting the content of the AppImage file, and then deleting the libraries in /usr/lib which are incompatible with the version of openldap of ubuntu 21.10.

./Shadow.AppImage --appimage-extract

then remove the libs in squashfs-root/usr/lib

then execute “shadow” in squashfs-root

It should work!

So I’ve tested on ubuntu and xubuntu.

same problem here on 21.10

I might add some more information though.

 

 ./Shadow.AppImage
libva error: vaGetDriverNameByIndex() failed with unknown libva error, driver_name = (null)
Checking for update
Update for version 5.0.1020 is not available (latest version: 5.0.1020, downgrade is disallowed).

 

as you can see libva error that’s not good, why would there be a libva error if we’ve installed

intel-media-va-driver-non-free
vainfo
libva-glx2

 

Do we have to do something else so that intel-media drivers replace the i965-va-driver ?

Anyway i965 was already used, and I had already the same error.

http://ix.io/3qn5

Does anyone has the same error of libva?

I have the same problem when I am on Wayland… But it works fine with X.org.

Userlevel 5
Badge +3

Hello @lavrenti 

Wayland is not supported by shadow.

yes indeed it was the wayland problem.

Now that I have excluded this libva error.

Do we have some workarounds about the R 0x7F? because I certainly have this error now.

Badge

@lavrenti has the answer for the R0x7F, marked as best answer !

 

I really have no clue what those libs are doing here ^^

 

Hello,

I found through the Discord channel that it is possible to fix this problem, by extracting the content of the AppImage file, and then deleting the libraries in /usr/lib which are incompatible with the version of openldap of ubuntu 21.10.

./Shadow.AppImage --appimage-extract

then remove the libs in squashfs-root/usr/lib

then execute “shadow” in squashfs-root

It should work!

 

Badge

@lavrenti btw on which Discord channel did you found it ?

Reply