SteelSeries Arctis Pro microphone not working

  • 16 September 2020
  • 2 replies

I have read several forum topics on microphone issues and also submitted a ticket to Shadow, but so far nothing has worked for me.

  • I am using a SteelSeries Arctis Pro USB headset. It works perfectly on my own computer. It's the only recording device currently enabled in the sound settings.
  • ​​​​​​​I have tried both forwarding the USB peripherals and just enabling the microphone in the Quick Menu. If I forward the USB, the microphone works but the audio is broken and laggy. If I only enable the microphone (without forwarding peripherals), the audio is fine but the microphone doesn't work at all.
  • The sample frequency is the same on my computer and Shadow (16-bit, 48000Hz), but my computer shows 2 channels and Shadow only shows 1 channel. I can't change either of them to match the other.
  • I have tried using the official client and the beta client, with the same result every time. I have also tried reinstalling my headset.

The only solution I can see is having a separate USB microphone and forwarding it, but that's less than ideal. Has anybody been able to fix this?

Thanks in advance.


Best answer by Zormac 16 September 2020, 23:47

View original

This topic has been closed for comments

2 replies

My mic just started working out of nowhere when I started my Shadow today, so please ignore this post. I couldn’t find an option to delete the thread.

I am having this issue with Arctis 7 Steele series. Exactly how you described it. I have tried the online “remedies” trying to resolve it.