Surface Go Type Cover Unresponsive after USB Peripheral enabled


After I enable USB Peripherals, install the drivers, and use the USB device on Shadow, my Surface Go’s Type Cover becomes totally unresponsive after I unplug the USB (while using Shadow).

This has happened twice now.


The first time I tried everything on the book (or on Google, to be sure), like restarting computer, uninstalling the Shadow USB drivers, disconnecting the Type Cover, using a DIFFERENT Type Cover, using my Type Cover on another Surface Go (and it worked), reinstalling drivers, etc. The only thing that fixed it back to normal was a hard reset, but of course that takes time to do and it’s a pain to reinstall and set everything back up.


Has anyone had this experience? Any solutions?

This topic has been closed for comments

2 replies

I did end up formatting the Surface Go AGAIN, and of course it’s working now. It seems that something happens with the drivers, because when I would try to go into the UEFI settings or even the BIOS, the Type Cover worked fine; only when I logged in to Windows did it not work.


I did not try Safe Mode or anything, though.


What I did try was:

Disconnect and re-connect it, several times.

Restart the PC, several times, with and without type cover.

Go into BIOS – Type Cover worked.

Download the Surface Repair Toolkit.

Download/install the latest Surface Go drivers from the MS website.

Try a different type cover on – it did NOT work

Try my type cover on my wife’s Surface Go – it worked on hers

I uninstalled all the devices under Keyboard on Device Manager, different ways, restarts and all, nothing.

Waiting for a Windows Update that got installed today – didn’t work

As mentioned, I uninstalled the drivers, restarted PC, even tried re-installing them, trying to use the USB peripheral on Shadow (as Bluetooth mouse still worked), and then uninstalled and restarted again…. Nothing


Another thing to note is that when the Type Cover was connected, it turned the lights one for half a second and thenn would not respond at all. No lights would come on, it’s as though it was unplugged – except that when you did disconnect it, the Surface would immediately go into Tablet Mode, and as soon as you’d connect the type cover, it’d flicker for half a second and the Surface would go into normal mode again.


Since Shadow is my main PC and I have a Surface Pro, reformatting this one isn’t the worst, but it is extremely tie consuming and of course, frustrating.


The last thing I want to share is that AFTER I reformatted, I enabled USB peripherals, I connected the USB mic, made sure it worked on Shadow, but before disconnecting it, I turned it off via the Quick Menu, and this way the Type Cover is working still. I did it a couple of times, but I did not try anything else in fear that it would happen again.

So to me, this confirms that it’s something to do with unplugging the USB while Shadow is active, though it could be something else.


I hope there is enough information there for hopefully find a solution!

Also I’m sorry I did not use the template.



  • Application type (Windows/Mac/Mobile/etc.)
    Windows 10 Surface Go

  • Shadow Client Version (Official/Beta/Alpha)

  • Local device CPU
    Pentium “Gold”

  • Local device GPU

  • Datacenter location (check

  • Connection speed (Datacenter speed tests EU: Paris | AMS or US: CA | TX |CH | NY)
    From mine? 50 mbps

  • Description of issue
    See post above. Short version: Type Cover stops responding *completely* after removing USB peripheral while running Shadow


  • Date when problem appeared.
    About a month ago and today

  • Did you take any action(s) which could have created this problem? If so, what?
    USB Peripherals activation and removing it while running Shadow

  • Do you recall any action(s) you took after it happened?
    See above

  • Do you use a VPN and/or antivirus?

  • Please provide a screenshot of your shadow stats (Alt+Win+O). Also make sure it captures a timeframe when the issue has happened.