USB Passthrough is not working

  • 29 December 2021
  • 1 reply


recently I started to use Shadow as Steam VR PC. I made my own VR gloves but I find a problem. The usb passthrough is not working with Arduino or ESP 32 boards. I can't see it in Device Manager in COM Ports. I tried programs like VirtualHere but there is too much latency. I am using a Mac Book pro M1 but it wont work on windows laptop either. Then I tried things like flash disk or headphones but it doest seams to work like on VirtualHere.

Thanks for response



Best answer by Dokitavi 23 January 2022, 11:32

View original

This topic has been closed for comments

1 reply

Hello !

Maybe instead of using ZeroTier you can try with Hamachi. Works perfectly fine for me ! 

here is the tutorial :

Whats needed :

Hamachi (

VirtualHere Server :

VirtuelHere Client :


Everything is working fine with the free versions of these softwares


Step by step procedure

On Local PC 

Launch the joystick driver in order to make it work on local pc

When recognized, launch Hamachi and create a network.

On Shadow :

Launch Hamachi

Join the network created on the local PC and connect the 2 PC on Hamachi

On local PC 

Launch VirtualHere server and install Bonjour client 

On shadow 

Launch VirtualHere client

-> All USB devices should appear in virtualhere client on shadow

Select the joystick.


Also don’t forget to check the windows firewall parameters. You have to follow this procedure both on the Shadow and on your local computer :