Solved

Video drivers/Nividia

  • 17 November 2020
  • 4 replies
  • 156 views

Userlevel 1
Badge +1

Good morning all.

So i have this crazy thing going on but not sure it’s a issue. Ok so i did my driver updates from nividia all good on that. So after that was done i did not see Nivida dash panel so i was ok. So i did the download to get that added to my pc but after i try to open it i get a your drivers do not support it. I did my drivers with geforce experience. Anyone can help me is this normal with a shadow pc.

 

icon

Best answer by Jim29er 18 November 2020, 16:01

View original

This topic has been closed for comments

4 replies

Userlevel 5
Badge +4

Do you mean you installed the Nvidia Control Panel from the Microsoft Store?

Since your Shadow VM is using a Quadro P5000, it is better to use “Quadro Experience” to manage the video drivers...you can download that from Nvidia. You’ll want to remove GeForce Experience first.

You likely already know this, but if you want to manage your video drivers yourself...you’ll want to turn off the “Keep my Shadow’s graphics drivers updated” in all of your clients. Managing the drivers yourself gives you the latest versions, although the Blade staff hasn’t necessarily vetted them for compatibility. I am managing mine through QE, and haven’t had any problems.

Userlevel 1
Badge +1

Do you mean you installed the Nvidia Control Panel from the Microsoft Store?

Since your Shadow VM is using a Quadro P5000, it is better to use “Quadro Experience” to manage the video drivers...you can download that from Nvidia. You’ll want to remove GeForce Experience first.

You likely already know this, but if you want to manage your video drivers yourself...you’ll want to turn off the “Keep my Shadow’s graphics drivers updated” in all of your clients. Managing the drivers yourself gives you the latest versions, although the Blade staff hasn’t necessarily vetted them for compatibility. I am managing mine through QE, and haven’t had any problems.

You are the best. Thank you so much for all the amazing help on this.

Userlevel 1
Badge +1

Do you mean you installed the Nvidia Control Panel from the Microsoft Store?

Since your Shadow VM is using a Quadro P5000, it is better to use “Quadro Experience” to manage the video drivers...you can download that from Nvidia. You’ll want to remove GeForce Experience first.

You likely already know this, but if you want to manage your video drivers yourself...you’ll want to turn off the “Keep my Shadow’s graphics drivers updated” in all of your clients. Managing the drivers yourself gives you the latest versions, although the Blade staff hasn’t necessarily vetted them for compatibility. I am managing mine through QE, and haven’t had any problems.

I also forgot to say yes i installed the Nvidia Control Panel from the Microsoft Store. Will Quadro Experience come with the control panel i need so i can adjust things.

Userlevel 5
Badge +4

I also forgot to say yes i installed the Nvidia Control Panel from the Microsoft Store. Will Quadro Experience come with the control panel i need so i can adjust things.

It should work, yes. I’m using QE and also have the Nvidia Control Panel installed from the Microsoft Store. I’m able to launch the Control Panel and see all the settings.