Solved

Xbox Controller recognised by Shadow but not in game

  • 11 June 2020
  • 8 replies
  • 982 views

Userlevel 1
Badge +1

Hey,

I just got a new Xbox Controller which I connected by Bluetooth on my Macbook, and also connected to my Android phone (not at the same time). The controller is immediately recognises by Shadow, on both devices, as I get a nice popup showing it is connected. On the Macbook it also shows up nicely in the controller menu in the Quick Menu. 

However, when I start a game on Shadow, in my case Fortnite, the game does not see the controller. It does not show the controller interface in the game menu, just the normal mouse and keyboard interface, while the Shadow Quick Menu still shows the controller is connected. Same result on Macbook and Android phone.

Do I need to do additional steps to enable the controller in a game? The Fortnite menu usually auto-detects the type of controller. In Youtube videos you can see people switch between keyboard and controller on-the-fly. There is no controller selection in the Fortnite menu, as far as I know.

I can use the controller just fine when I run Fortnite natively on my Android phone, so it is not broken.

I am running Shadow Beta on all devices.

icon

Best answer by dynam1ke 9 July 2020, 21:37

View original

8 replies

Userlevel 5
Badge +3

Install steam and add fortnite as a non steam game. Launch the game through steam big licture mode. Before doing so go to ctonroller settings and tick xbox. 

Userlevel 1
Badge +1

Thanks for the reply @Gaijin . I tried it. It did not work. I am able to control the Steam Big Picture Mode with the controller, but the controller does not work when Fortnite started. It is also possible to force ON the controller in Steam Big Picture, which makes Fortnite show the controller interface of Fortnite on the first menu, but still the controller does not react.

Is there someone playing Fortnite using a controller on Shadow?

Userlevel 1
Badge +1

Is it correct that, on the Shadow PC, my Xbox One Controller shows up as Xbox 360 controller in Windows Device Manager? The Shadow Quick Menu shows in controllers 'Xbox One S Controller (1708) (Bluetooth)'.

The controller also works in the Windows Xbox App on Shadow PC.

Then why not in Fortnite?

Userlevel 5
Badge +3

There is an issue with fortnite & mac os catalina. 

you might want to have a look here:

https://www.reddit.com/r/macgaming/comments/ev2hj3/xbox_controller_for_fortnite_on_mac/
the workaround is posted in that thread but you will have to install an additional driver locally & wire up your controller. 

Userlevel 1
Badge +1

Hmm, but Fortnite on Mac is a bit different from Fortnite on Shadow on Mac, right?

Because I have the same issue whem attempting Fortnite on Shadow on Android.

Userlevel 5
Badge +3

Hmm, but Fortnite on Mac is a bit different from Fortnite on Shadow on Mac, right?

Because I have the same issue whem attempting Fortnite on Shadow on Android.

I use reWASD on shadow as this sorts any controller issues for me. As long as the device running shadow recognizes the controller reWASD turns it into a ps or xbox controller on shadow. 

Userlevel 1
Badge +1

Hmm, but Fortnite on Mac is a bit different from Fortnite on Shadow on Mac, right?

Because I have the same issue whem attempting Fortnite on Shadow on Android.

I use reWASD on shadow as this sorts any controller issues for me. As long as the device running shadow recognizes the controller reWASD turns it into a ps or xbox controller on shadow. 

I installed reWASD but no success.

The controller is recognised by reWASD as a xbox360 controller. I can make it rumble. I can change buttons. Everything works. Only not in Fortnite. 

Maybe the EasyAntiCheat system Fortnite uses blocks the Shadow emulated controller input?

Userlevel 1
Badge +1

I finally found the solution to my issue, and it is so stupid...

In the Fortnite Mouse and Keyboard settings (Yes! Mouse and Keyboard settings, you heard it corectly) there is an option to 'Ignore gamepad input'. I have never seen or touched this setting, but it was set to 'On', blocking my Xbox controller. Setting this off made the controller work 100% the way it should on all my Shadow devices. 

I have no clue why this was set to 'On', or if it was default setting. I wasted a lot of time and effort on this...

Reply