Xbox Series X|S Controller (Model 1914) exhibits strange behavior on Zorin OS (Ubuntu derivative)

  • 2 September 2022
  • 2 replies


I’ve been using Shadow for almost a month now and I’ve found the service to be quite nice (when it works correctly, which is most of the time, and the games I want to run run). Up until now, I’ve been using a Turtle Beach Xbox Recon Controller, which served me pretty well in gaming sessions when I’m not doing work. However, because it requires a wire to function, at least one port on my laptop (besides power) needs to be available for connection. I wanted to get a wireless controller, to eliminate wires, and so I recently purchased an Xbox Series X|S Carbon Black official controller and tried to use it wirelessly.

On the host Linux distro (Zorin OS 16.1 Core), the controller is perfectly functional, both wired and wireless; all of the buttons work as intended. No problems. It is when I try to connect to my Shadow PC wirelessly, however, that issues start to occur. To make a long story short, the controller is completely misconfigured and I’m not sure if its a driver issue or something on Shadow’s end that has to be remediated at the kernel level.


I have taken the time to compile a list of what buttons do what (or not):

Face buttons

A: A

B: B

Y: Left Bumper

X: Y

4-way direction pad: works

Shoulder Buttons

Right Bumper: Start

Left Bumper: Select

Left Trigger: Right Trigger

Right Trigger:

Unpressed, right joystick all the way up

Pressed, right joystick all the way down

Problem Buttons

Select: Right joystick click

Start: doesn't register

No button is registered for "X"

I hope this list makes sense, because it’s really hard to show this without an in-person side-by-side.


This is a screenshot from Gamepad Tester, after briefly engaging the right trigger. It is stuck in this state.

It could be that it’s being recognized as an Xbox 360 Controller, but I can’t find any drivers specifically for “Xbox Series X Controller”. Also, there are no duplicate entries found in Device Manager, that would cause redundant inputs, when it is first initialized into the system; I already looked.

This topic has been closed for comments

2 replies

Userlevel 1
Badge +1

I haven't used Linux for a while so I'll try to help where I can. Can you try this wired and see if you have the same issue?


I just tried the Xbox Series X|S controller wired and, yes, it does in fact work correctly--all of the buttons function as intended. I went into Device Manager, and it is registered as “Xbox 360 Controller for Windows” (same as wireless).

I went into Event Viewer, and there’s a bunch of flags in Administrative Events for errors saying “windows: failed to detect games” and warnings about “class ps:WindowsGameProviderChannel: game detection already in progress”, but nothing related to the controller. So, it works while physically connected, but not using Bluetooth.

Due to complications with a recent failed Uplay installation, I was forced to reset my Shadow because it had become unusably unresponsive (something like ~132ms latency) to factory condition. It is now more responsive than when I initially got it, but the issue remains. Also, I ran these same tests on a Windows host (both before and after the reset) and the button misconfiguration is absent.